Zope.org breakdown and old Plone's versions.cfg

Seems that download.zope.org is down.

I know that recent Plone are no more referencing to it for Zope version pinning, but what about old Plone?
I've a Plone 4.1 buildout that now is freezed trying to download http://download.zope.org/zopetoolkit/index/1.0.7/zopeapp-versions.cfg

Have we a copy of those cfgs somewhere?

1 Like

Ok it seems we have also old ones on http://dist.plone.org/versions/ (at least, ones needed by Plone 4.1.6 are there :slight_smile: )

Also, every Unified Installer has copies. https://github.com/plone/Installers-UnifiedInstaller/tree/4.3.9/base_skeleton for example for 4.3.9.

Thanks.

I'm wondering if it's not better to modify all old versions.cfg to point to plone.org hosted zope .cfg, for example http://dist.plone.org/release/4.1.6/versions.cfg

Meanwhile: download.zope.org is still down.

I don't think this is good for Plone community. Any chance to ping anybody from the Zope community about this?

It's not only download.zope.org but also docs.zope.org which holds essential documentation including the zope2book. Also old.zope.org is down that still held some interesting resources. Who do we need to talk to to get these up again?

We are getting the same problem with one Plone 4.2 test https://travis-ci.org/collective/collective.js.cycle2/jobs/146177538

Hello,

I could reach @gotcha during his holiday. He gave me access to server management and had a clean reboot. Services should be back. We will speak together how to improve this when he is back.

Cheers,

Jeff

2 Likes

Great, thanks!

It seems to be down again...

1 Like

Related:


Workaround:

@tkimnguyen do you have any idea if we can merge all of these posts since they're talking about the same topics?

@jfroche any news about returning these services back?

Since you have access to the server, would it be the case to copy verbatim what is in download.zope.org (Here is an example https://web.archive.org/web/20161113090031/http://download.zope.org) and put in dist.plone.org so a changing in /etc/hosts would be a new workaround as well to legacy buildouts?

Hello,

I contacted Jim and Tres about this issue on Wednesday (30/8). I haven't heard from them yet. The problem seems to be related to unpaid invoices for the hetzner servers.

If we don't have news on Monday, we (Affinitic) will pay a last time before migrating what's required on the plone infra (could the foundation help here ?).

Jeff

Yeah I was going to suggest we find a way to export those sites' content and move things to a Plone Foundation server, and fix everything that points to the old URLs. @jfroche could you email board@plone.org with such a plan? We all appreciate Affinitic's help (financial and human)!

It's not really well supported... apparently "moving" really just copies. https://meta.discourse.org/t/merge-two-topics-into-one/9735

Ugh or it just sounds hairy. https://meta.discourse.org/t/how-to-merge-two-messages/45290

This is what the UI tries to do: discourage duplicate topics by suggesting how your topic is similar to existing topics, but if people can't be bothered to search first or to look while they're typing :slight_smile: https://community.monzo.com/t/merging-duplicate-topics/6248/23

We still think the /etc/hosts idea would be nice to test if the downloads.zope.org export keeps the same directory layout in dist.plone.org, and the docs updated to show this workaround and @cdw9's.

You indeed can fix everything in plone and collective do avoid using this url in the future, but people may have lots of legacy systems that will have this error, so if we can ease the pain of upgrading Plone to integrators it would be really nice.

1 Like

Any news?

We got confirmation from Jim that the Zope foundation treasurer will pay the invoices for this month. Keep you posted

1 Like

Still no news yet?

I tried the workaround but it didn't work for me.

Just FYI, zope.org is reachable again.
Changing the versions.cfg on plone.org was discussed in this thread.

Looks like its down again now... :frowning:

ping: unknown host download.zope.org

Error: Error downloading extends for URL http://download.zope.org/zopetoolkit/index/1.0.7/zopeapp-versions.cfg: <urlopen error [Errno -2] Name or service not known>