Where can I find the "Extensions-Folder" en Plone 4.3.11?


I'm still using a webpage with Plone 2.0.5, but now it's time to change to a newer version of Plone (4.3.11). In my old Plone installation I have an "Extensions-Folder" in /opt/Zope-2.7.8/instance1/Extensions, but I can't find that folder en 4.3.11. Do I have to create it? Where?

Maybe in /opt/Plone/zeocluster/parts/client1/ and /opt/Plone/zeocluster/parts/client2/, or in /opt/Plone/zeocluster/parts/zeoserver/ ??? I don't know where...

Thanks for help,

1 Like

External methods (i.e. the scripts inside Extensions folder) are deprecated and currently recommended to be replaced by a browser view inside one of the project's packages.

That said, they might still be usable: http://ezhaar.blogspot.com.br/2012/06/external-methods-in-plone-4.html


+1 to what @davilima6 said,

but if you really need to. Then you can create it at <buildout_dir>/parts/<instance_name>/Extensions
where <instance_name> is probably just "instance"!

I did it in order to use collective.jsonify on a (Development) Plone 4.1 instance this week - still works.

BUT this is old tech, there maybe security issues with using this in Production

Just notice that the parts/ directory is deleted and rebuilt every time you run buildout so it's best not to manually maintain files there.

Hi Davi,

I tried the configuration of you link in base.cfg:

zope-conf-additional = extensions ${buildout:directory}/Extensions

But Plone isn't searching External Methods in this directory (after buildout and restart). But after creating a filesystem link in ${buildout:directory}/parts/client1/Extensions it works. So it seams that the configuration line doesn't work. Why not?

Maybe because couldn't find a [instance] group, therefore I inserted it in [instance-base] group...
Do I have to create a[instance] group in base.cfg?

Any help?


I tested and it works. You may check if there's a line starting with "extensions" in parts/client1/etc/zope.conf and whether it points to the desired folder.

The name of the section doesn't matter as long as it's controlled by the plone.recipe.zope2instance recipe. Btw see:

Hmm, can't find that in zope.conf... So it seams that my configuration doesn't work...
Maybe I have to write that like this part:

products = ${buildout:directory}/products

For instance:

extensions = ${buildout:directory}/Extensions


No, syntax is correct, as you can see if you look for zope-conf-additional in the first link I sent. Did you run buildout after making those changes? If so could you please post your CFG files here?

Sorry, but it's only working doing it in the [client_base] section! Now it's solved.

Thanks for your help!

!!! :slight_smile: