Python version used by Plone 5

ello everyone
I would like to know how to check which installation of python (the version that installs with plone or the one we installed ourselves) is used by Plone 5.
In the same vein, I would like to know how to tell Plone 5 which version or installation of Python to use.
If anyone has an idea thank you for helping me.

check the scripts bin/instance or bin/zeoclient...they should have the path to the interpreter used in the shebang.

Thank you Andreas,
Indeed the path is well indicated just after the shebang.
It is the python program installed with Plone 5 which is indicated and not python 2.7.16 that I installed and declared to the path.
It is troubling. Indeed, when I installed Plone 5.1.4, I had error messages during startup. Indeed it pointed to Python 3.7.3 installed.
It was by decoding the error message that you helped me understand that.
At the time, the problem had stopped as soon as I declared and put Python in the path.
Thanks for your help.

How did you install Plone, with the unified installer?

Absolutely, I installed Plone with Plone-5.1.5-UnifiedInstaller.

What command line arguments did you provide it? I’m curious whether you specified a particular Python version and how you did that with the installer

The unified installer checks the system Python for suitability and uses it if it is suitable, otherwise it stops to ask you what you’d like to do. One of the choices is for it to build a suitable Python version, which it would place inside the target directory containing the Plone installation

Thank you for your reply.
In general when I want to install for example Plone 5.1.5 under Windows 10, I place
"Plone-5.1.5-UnifiedInstaller" uncompressed on partition C.
Then I proceed as follows:
C: > cd Plone-5.1.5-UnifiedInstaller
C: \ Plone-5.1.5-UnifiedInstaller> windows_install.bat standalone -password = XXX
From then on, he installs me Plone in the default path under Windows.
Indeed, it is still not possible to install Plone 5 at the desired location on Windows. I had already reported this problem.
When trying to installPlone 5 at a location chosen by us, it generates a completely incomplete "zinstance".

Could you post here the link to the problem you reported earlier?

First of all, thank you for your answer.
Here is the link :Unable to start a new installation of Plone 5.1.4 on Windows [RESOLVED]

The problem N2 was solved when I suggested to use "insatnce fg" to launch the server.
On the other hand, the problem No1 remains.
Indeed it is impossible to choose its installation directory of Plone 5 under Windows.
To install Plone 5 on Windows, you must leave the default directory for installation.
Anyone have an idea about it?

1 Like