Plone 5.1rc1 soft-released

Plone 5.1rc1 has been soft-released. Please give it a try and let me know if there are any critical issues.

For those who haven't run across soft-releases before, this is the
last step before the final release. Because things haven't been
finalized yet, some packages may change between now and the release. It
is not recommended to use soft-releases in production.


Attempted an upgrade from 5.1a2 to 5.1rc1 and it failed

Upgrade aborted. Error:
Traceback (most recent call last):
  File "/home/ubuntu/workspace/eggs/Products.CMFPlone-5.1rc1-py2.7.egg/Products/CMFPlone/", line 268, in upgrade
  File "/home/ubuntu/workspace/eggs/Products.GenericSetup-1.8.8-py2.7.egg/Products/GenericSetup/", line 166, in doStep
  File "/home/ubuntu/workspace/eggs/", line 188, in move_safe_html_settings_to_registry
    settings = registry.forInterface(IFilterSchema, prefix='plone')
  File "/home/ubuntu/workspace/eggs/plone.registry-1.1.2-py2.7.egg/plone/registry/", line 82, in forInterface
KeyError: 'Interface `Products.CMFPlone.interfaces.controlpanel.IFilterSchema` defines a field `valid_tags`, for which there is no record.'
End of upgrade path, main migration has finished.
The upgrade path did NOT reach current version.
Migration has failed

I ended up first upgrading to 5.1b4 (configuration 5107)

Attempting an upgrade from 5107 to 5108 still failed with the same error as above.

We should add a version-pinn for enum34 which is a dependency for pyScss:

enum34 = 1.1.6

I found another case of not yet registered safe_html settings when migrating 5.0.8 to 5.1rc1. Fixed with

Actually it is the same that @pigeonflight found.



Will test as soon as the updated is released.

Is it by intend/ with reason, that the Mosaic dependencies are outdated in the RC1?

We might consider updating ZODB to 5.3.0. I run into this issue with the currentyl pinned 5.2.4

1 Like

There is another issue with
As I mention in the PR we probably need another upgrade-step for cases when the the registry holds a unicode-value and we only run migrations from 5.0.x to 5.1.x. I may have time to test that on thursday.

Also there is this issue with CMFDefault:

If someone can give me the correct versions for the mosaic packages, or update the 5.1 versions.cfg, I'll make sure that's added to the release.

Added this and the enum34 pin. I'll update the release as soon as the tests are done.

@esteele please review those two fixes - I think they are needed for the 5.1rc1 release:

I tested 5.1 rc1 this morning but I've some strange issues.

Firt: I was forced to add some low level eggs to ignores settings for the omelette buildout recipe due to strange errors:

recipe = collective.recipe.omelette
eggs = ${instance:eggs}
ignores =

After fixing this the buildout runs and Zope starts but then I've a lot of exception captured by PDBDebugMode:

BadRequest: ('Empty or invalid id specified', u'temp_folder')
> /Users/keul/Library/Buildout/eggs/Zope2-2.13.26-py2.7.egg/OFS/
-> raise BadRequest, ('Empty or invalid id specified', id)
(Pdb) !id
(Pdb) l
 89  	    import Globals  # for data
 91  	    if not id or not isinstance(id, str):
 92  	        if isinstance(id, unicode):
 93  	            id = escape(id)
 94  ->	        raise BadRequest, ('Empty or invalid id specified', id)
 95  	    if bad_id(id) is not None:
 96  	        raise BadRequest, (
 97  	            'The id "%s" contains characters illegal in URLs.' % escape(id))
 98  	    if id in ('.', '..'): raise BadRequest, (
 99  	        'The id "%s" is invalid because it is not traversable.' % id)

Here id is an unicode instead of a string, so I get the error.
Switching back to 5.1b4 fix the problem.

I'm the only one with this problem?

I also got this error.
On buildout.coredev it's already solved.
See this discussion:

1 Like

I've updated the release on with the new version pins.


I checked the new pinns against a 5.0.8 project and the upgrade to 5.1rc1 was without issues.

Fantastic. Thanks @pbauer. I've removed the -pending flag.


Thanks! now supports 5.1rc1

The upgrade now runs successfully, but when I attempt to visit a newsitem I get:

Traceback (innermost last):
  Module Products.PloneFormGen.patches, line 21, in safe_render
  Module Products.Five.browser.pagetemplatefile, line 125, in __call__
  Module Products.Five.browser.pagetemplatefile, line 59, in __call__
  Module zope.pagetemplate.pagetemplate, line 137, in pt_render
  Module, line 98, in __call__
  Module, line 163, in render
  Module chameleon.zpt.template, line 261, in render
  Module chameleon.template, line 191, in render
  Module chameleon.template, line 171, in render
  Module, line 320, in render
  Module, line 161, in __call__
  Module plone.portlet.static.static, line 183, in transformed
  Module Products.PortalTransforms.TransformEngine, line 171, in convertTo
  Module Products.PortalTransforms.chain, line 45, in convert
  Module Products.PortalTransforms.Transform, line 196, in convert
  Module Products.PortalTransforms.transforms.safe_html, line 2390, in convert
  Module plone.registry.registry, line 82, in forInterface
KeyError: 'Interface `Products.CMFPlone.interfaces.controlpanel.IFilterSchema` defines a field `valid_tags`, for which there is no record.'

 - Expression: "view/transformed"
 - Filename:   ... et.static-3.1.1-py2.7.egg/plone/portlet/static/
 - Location:   (line 21: col 36)
 - Source:     ... v tal:replace="structure view/transformed" />
... snip ...

TransformError: Error during transformation

 - Expression: "python:context.text.output_relative_to(view.context)"
 - Filename:   ... egg/plone/app/contenttypes/browser/templates/
 - Location:   (line 15: col 29)
 - Source:     ... ucture python:context.text.output_relative_to(view.context)"

This is similar to the error that was preventing the upgrade from running which also made reference to:

KeyError: 'Interface `Products.CMFPlone.interfaces.controlpanel.IFilterSchema` defines a field `valid_tags`, for which there is no record.'