Plone 4.3.15 soft-released

Plone 4.3.15 has been soft-released. Please give it a try and let me know if there are any critical issues.

For those who haven't run across soft-releases before, this is the
last step before the final release. Because things haven't been
finalized yet, some packages may change between now and the release. It
is not recommended to use soft-releases in production.


plone.recipe.zeoserver: 1.3 → 1.3.1
Bug fixes:

- Fix tests to run with current Twisted version.

plone.recipe.zope2instance: 4.2.22 → 4.3
New features:

- Added ``storage-wrapper`` option to wrap storage configuration.
  [davisagli] 1.0.3 → 1.1.1
New features:

- Add new variable ${SELENIUM2LIBRARY_RUN_ON_FAILURE} with default value
  'No operation' (Robot Framework built-in keyword with no action) to define
  operation immediately after failed Selenium keyword

Bug fixes:

- Update links to external documentation.  [jensens]

- Fix issue where an error "No keyword with name 'No keyword' found." after
  a failing test was reported

Plone: 4.3.14 → 4.3.15
New features:

- Release Plone 4.3.15

Products.Archetypes: 1.9.13 → 1.9.17
Bug fixes:

- Don't instantiate browser view to check for existence.

- Fix bug in BaseObject SearchableText when vocabulary key is uft8 encoded string

- Fix bug with Widget's postback attribute, that prevented fields from
  being populated with the submitted empty value in the case of an error.

- Use ``$`` instead of ``jq`` in ``textcount.js``.
  This is for example used by PloneFormGen when you set a
  maximum character count for a text field.  [maurits]

Products.CMFCore: 2.2.9 → 2.2.10

Products.CMFPlone: 4.3.14 → 4.3.15
Bug fixes:

- Review context url for @@render-portlet and @@updateSharingInfo ajax calls.
  Fixes `issue 2053 <>`_.

Products.GenericSetup: 1.8.6 → 1.8.8
Bug fixes:

- Fixed ``upgradeStep`` discriminator so that similar steps
  for different profiles will not conflict.

- Fixed ``upgradeDepends`` discriminator so that steps inside
  ``upgradeSteps`` will conflict with steps outside if they
  have the same ``checker``.

- Allow registering the same profile twice if it really is the same.
  This is mostly for tests where the registry may not be cleaned up
  correctly in case of problems in test teardown.
  If you register the same profile twice in zcml, you still get a
  conflict from ``zope.configuration`` during Zope startup.

Products.PlonePAS: 5.0.13 → 5.0.14
Bug fixes:

- Remove WarningInterceptor (CMFCore) - it is gone in newer versions.

Products.TinyMCE: 1.3.26 → 1.3.27
Bug fixes:

- Add missing import in the DX anchor view module. [mbaechtold] 1.5.17 → 1.5.19
Bug fixes:

- Fixed syntax error in tests with Python 2.6.  [maurits]

- Handle ``ValueError`` exceptions when doing a range request.
  This fixes `issue #39 <>`_.
  [batlock666] 1.1.11 → 1.1.12
Bug fixes:

- Fixed title and description of max age in strong caching rule for resources.
  They wrongly were the same as for shared max age.
  Fixes `issue 1989 <>`_.
  [maurits] 1.9.1 → 1.9.2
Bug fixes:

- Update ``Gruntfile.js`` with master branch of collective/jquerytools.
  Update docs with info about our jQuery Tools fork.
  [thet] 4.2.5 → 4.2.6
Bug fixes:

- Do not load Products.SecureMailHost zcml.
  It is not needed in Plone 4.  [frisi] 1.4.1 → 1.4.2
Bug fixes:

- Fixed title and description of plone.resource.maxage.
  This had the title and description from shared maxage,
  due to a wrong reference.

plone.namedfile: 3.0.10 → 3.0.11
Bug fixes:

- Fix contentType attribute should be str type, what leads to validation errors (fixes `#38`_).

plone.subrequest: 1.8 → 1.8.1
Bug fixes:

- Remove unittest2 dependency

plone.transformchain: 1.2.0 → 1.2.1
Bug fixes:

- Remove unittest2 dependency
  [kakshay21] 1.1.1 → 1.1.2

plone.directives.form: 2.0.2 → 2.0.3
Bug fixes:

- Remove unused import and added a missing import on example.

- Update to point to github repository.

@idgserpro this is still open, are you going to work on it?

@hvelarde we still can't contribute to plone source code, we're still in touch with our legal department. We're in debt with some documentation PR's too.

@esteele and @smcmahon, please don't forget to update as well. In there the last tag for Plone 4.3.x is 4.3.12, we talked about this situation when 4.3.14 was being release (check

Dexterity TTW is broken in 4.3.15-pending ( as well as 4.3.14 ) :

Reproduce :

  • create new plone site, select 'dexterity' add on
  • go to the dexterity control panel and create a new type, within this new type, add a field 'RichText'
  • go to the plone normal interface, and add an object based on the new type , complete the fields with text

When saving and viewing the page, the RichText Renders as 'RichTextValue object. (Did you mean .raw or .output?)'

The locking mechanism when editing objects is also still broken. See here the issue reported for 4.3.14.

I tried 4.3.15 on two sites and it seems fine.

@esteele An option could be to downgrade to 1.2.7. This avoids the error that @gnafou reports for dexterity rich text fields created TTW. See But that problem is already there in 4.3.14.

Thanks for the fix, @mauritsvanrees. I've bumped that to 1.2.9 in the versions.cfg and pushed 4.3.15 out of the pending state.

1 Like

I have not noticed problems with search or sending emails. Please check if this is reported in an issue at and create a new issue there if it has not been reported yet.

Sorry, the third-party add-on caused the error

Same problem, the locking mechanism when editing objects is still broken. Let's downgrade for the moment.

The fixes for this problem are going to be live earliest with Plone version 4.3.16.

I noticed no buildout-cache.tar.bz2 was generated for Plone 4.3.15; do you need some kind of help, @esteele?