Ability to create hyperlinks broken [RESOLVED]

We’re experiencing some bizarre behavior with our Plone 4.3.1
install. It is on a Windows 2012 Server. First the ability to link pages broke.
I would highlight a word, click the hyperlink icon in the TinyMCE toolbar, pick
a page, click ok, and nothing would happen. No hyperlink was generated. Now,
when I try to create a hyperlink, I don’t even get a list of page to which I
can link. Example below:

I restarted the Plone service, then tried running
buildout.exe. During the buildout.exe process, these following errors showed

Updating backup.
Updating zopepy.
Updating precompiler.
Compiling Python files.
SyntaxError: ('invalid syntax',
30, 17, ' x = {y: y f
or y in whatever if y}\n'))

SyntaxError: ('invalid syntax',
6, 13, ' {y: y for
_restricted_name in x}\n'))

Compiling locale files.
Error while compiling c:\plone43\eggs\python_gettext-1.2-py2.6.egg\pythongettext
Error while compiling
Updating run-instance.
Updating service.
*************** PICKED VERSIONS ****************
netsight.windowsauthplugin = 2.3.1

*************** /PICKED VERSIONS


Could these errors be what is causing the issue with
hyperlinks? Or?

Version Overview

Plone 4.3.1 (4306)
CMF 2.2.7
Zope 2.13.20
Python 2.6 (r26:66721, Oct  2 2008, 11:06:43) [MSC v.1500 64 bit (AMD64)]
PIL 1.7.8 (Pillow)

Thank you in advance.

Clark Dilley

no, you can safely ignore those messages; try to upgrade your instance to the latest Plone version in that branch, that is Plone 4.3.9, and see if the problem is solved.

if not, come back here later.

Also, open the developer console to look if any requests fail. Because when you open the view, an url is loaded in the background, if that fails, you see it there and can try to open that request manually.

I have the same problem with Plone 4.3.1 and after an update to 4.3.9 the error occurs to.
Does anybody has an idea or a solution for this problem?

Thanks a lot.

Are you saying you had the problem with 4.3.1? or you had the problem only after upgrading to 4.3.9?


unfortunality both. I had the problem with 4.3.1 and after an upgrade to 4.3.9 the problem is alreay existing.

The problem went away after I did a reinstall of 4.3.1, but then it came back a few days ago. I tried a different browser and it allowed me to make links again. Very strange behavior and a little discouraged. I tried to do an upgrade to 4.3.9 and that was not friendly. Also tried to do an upgrade to 5.0 and the upgrade would not accept the netsight.windowsauth plugin which means that is not an option for me. I will keep trying and post any updates I discover.

Look in your browser console for JavaScript error messages

You're right, there are any error messages

TypeError: jq is not a function

I think the error is with jquery. But for some days the window for setting links appeared without any problems and suddenly the error occurs.

There could be many reasons why jQuery isn't loading, e.g. you activated another add-on, you upgraded an add-on, a javascript resource is no longer being loaded (check portal_javascripts).

1 Like

I wonder, if meanwhile somebody found a solution to this problem.

We're experiencing the same issue here, the "plonebrowser" of TinyMCE stopped working, it isn't possible to choose internal links or images. JavaScript console says:

Uncaught TypeError: jq is not a function
    at BrowserDialog.init (plonebrowser.js:65)
    at Array.<anonymous> (tiny_mce_popup.js:5)
    at Object.each (eval at <anonymous> (:8080/PI/portal_javascripts/Sunburst%20Theme/++resource++plone.app.jquery.js:2), <anonymous>:1:2159)
    at _onDOMLoaded (tiny_mce_popup.js:5)

This happens with installations on:

Windows Server 2008, Plone 4.3.2, Python 2.6, TinyMCE 1.3.5
MacOS 10.12,  Plone 4.3.2, Python 2.6, TinyMCE 1.3.5

using browser Firefox and Google Chrome.

Wie upgraded the MacOS Plone to

Mac OS 10.12,  Plone 4.3.14, Python 2.7, TinyMCE 1.3.26

but the problem still persists.

In a newly created Plone Site TinyMCE plonebrowser is working without problems, so I think, it must persist somewhere in the DB.

Also, is there a possibility to debug TinyMCE to find out, why jQuery isn't loading?

Any help would be highly appreciated!

Thanks in advance

Can you look in your browser's inspector console to see what errors are shown?

Do you mean besides the JS error messages mentioned above?

Ah sorry - I see them now :slight_smile: What add-ons do you have in there?

As eggs in buildout.cfg:

eggs =

and ZMI > portal_quickinstaller:

Installed Products
Product Version at Install time Product version
Plone JQuery Integration 1.7.2 1.7.2
Plone JQuery Tools Integration 1.5.6 1.5.6

In Production mode I also have


but I uninstalled them for Testing.

Isn't there a straightforward way to debug the JS of TinyMCE from the moment of pressing the toolbar button until the display of the empty browser window?

Also, would upgradint to Plone 5.x be a way to go (although I'm scared about the work vor upgrading LinguaPlone, which I need, to plone.app.multilingual

Someone else who has experience with Plone 4 and LinguaPlone will have to jump in. I'd be surprised if you had this problem with a bare Plone 4 buildout, so I assume it's got to do with an add-on.

Also, you say you started having this problem, so what changed in your buildout or stack?

I went back in time with a backed up Data.fs and I have now an instance without problems, same buidout.cfg. I'll analyze the user actions between the two states to hopefully isolate the problem. I can endeed well imagine that there was an issue with translations.
Anyway, thanks a lot for your help so far!

1 Like

Hurrah for good backups!

Could you look through your site's Undo tab (via the ZMI)?

Yes, this is the plan!