ZopeXml Configuration error

I am facing the ZopeXml Configuration error related to the addons. I messed up with a migration attempt and now I am trying to recover back. I am currently on plone 5.0.5

Check your GenericSetup Version. 1.8.2 or higher is needed to support post_handler.

thanks. i could resolve it by some trial and error process. essentially the version pin on one of the addons. The version pin was not there when installed and hence errors raised later.

Plone Foundation Code of Conduct