[zodbverify] Error: The requirement ('transaction>=2.4') is not allowed by your [versions] constraint (1.1.1)

Plone 4.3.18

I am trying to check a ZODB using zodbverify according to


I added zodbverify to eggs. Buildout gives me this error:

Version and requirements information containing transaction:
  [versions] constraint on transaction: 1.1.1
  Requirement of Zope2==2.13.28: transaction
  Requirement of ZODB3>=3.9: transaction>=1.1.0
  Requirement of ZODB: transaction>=2.4
  Requirement of Products.CMFPlone: transaction
  Requirement of Products.Archetypes: transaction
  Requirement of gocept.cache: transaction
  Requirement of Products.ZCTextIndex: transaction
  Requirement of Products.StandardCacheManagers: transaction
  Requirement of zope.sendmail: transaction
  Requirement of transaction: zope.interface
  Requirement of AccessControl>=2.13.16: transaction
  Installing instance.
Error: The requirement ('transaction>=2.4') is not allowed by your [versions] constraint (1.1.1)

zodbverify is not compatible with earlier versions than 5.2. It was only added to CMFPlone in 2018 and soon moved to a separate package but has always used internals of ZODB 4.

For older Plone-Verions you can use the script fsrefs in ZODB:

./bin/zopepy ./parts/omelette/ZODB/scripts/fsrefs.py -v var/filestorage/Data.fs

Just following the docs...or?

Not really. The docs say "1. Upgrade your site to Plone 5.2 running on Python 2 first" unter Database Upgrade Procedure. Only step 5 mentions zodbverify.