Windows 7 x64 upgrade from 4.3.1 vanilla to 4.3.15 ... trying variations

I am trying all combinations to upgrade to 4.3.15
I installed a vanilla version using the 4.3.1 windows replaced the buildout.cfg from 4.3.1 with the buildout from 4.3.15 tar.gz
Ran c:\plone43\bin\buildout -n -vvvvvvvvv

File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\command\easy_inst
all.py", line 655, in install_eggs
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\command\easy_inst
all.py", line 930, in build_and_install
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\command\easy_inst
all.py", line 919, in run_setup
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py", line
62, in run_setup
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py", line
105, in run
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\sandbox.py", line
64, in
File "setup.py", line 69, in
File "C:\Plone43\python\lib\distutils\core.py", line 113, in setup
_setup_distribution = dist = klass(attrs)
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\dist.py", line 26
0, in init
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\dist.py", line 28
4, in fetch_build_eggs
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\pkg_resources.py", line 563,
in resolve
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\pkg_resources.py", line 799,
in best_match
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\pkg_resources.py", line 811,
in obtain
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\dist.py", line 32
7, in fetch_build_egg
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\command\easy_inst
all.py", line 434, in easy_install
File "c:\plone43\eggs\setuptools-0.6c11-py2.6.egg\setuptools\package_index.py"
, line 475, in fetch_distribution
AttributeError: 'NoneType' object has no attribute 'clone'
An error occurred when trying to install Products.CMFCore 2.2.10. Look above thi
s message for any errors that were output by easy_install.
While:
Installing instance.
Getting distribution for 'Products.CMFCore==2.2.10'.
Error: Couldn't install: Products.CMFCore 2.2.10
*************** PICKED VERSIONS ****************
[versions]
products.plonehotfix20130618 = 1.1

*************** /PICKED VERSIONS ***************

C:\Plone43>

My question relates to the change from Py26 (4.3.1-4.3.12) to Py27 (4.3.15) and easy_install.py??

Also manually upgrading setuptools and zc.buildout to start with.

This would be to get a vanilla copy of 4.3.15 with the database being upgraded later

Any assistance is appreciated

I don't understand your question: Plone 4.3 should run in both Python 2.6 and 2.7.

on the other side, my recommendation is:

  • enable your virtualenv
  • update your setuptools to the version used in Plone 4.3.15 (pip install -U setuptools==26.1.1)
  • run buildout again

Hi hvelarde
That worked for me, a little tweeking on a couple of .cfg files and it compiled.

localhost:8080 came back with unable to connect

c:\plone43\bin\buildout -D indicated python-gettext needed an upgrade.

Tried the following and got the following error
IndentationError: unexpected error

C:\Python27\Scripts>pip install -U python_gettext==3.0
Collecting python_gettext==3.0
Downloading python-gettext-3.0.zip
Exception:
Traceback (most recent call last):
File "c:\python27\lib\site-packages\pip\basecommand.py", line 215, in main
status = self.run(options, args)
File "c:\python27\lib\site-packages\pip\commands\install.py", line 324, in run

requirement_set.prepare_files(finder)

File "c:\python27\lib\site-packages\pip\req\req_set.py", line 380, in prepare_
files
ignore_dependencies=self.ignore_dependencies))
File "c:\python27\lib\site-packages\pip\req\req_set.py", line 634, in _prepare
file
abstract_dist.prep_for_dist()
File "c:\python27\lib\site-packages\pip\req\req_set.py", line 129, in prep_for
dist
self.req_to_install.run_egg_info()
File "c:\python27\lib\site-packages\pip\req\req_install.py", line 412, in run

egg_info
self.setup_py, self.name,
File "c:\python27\lib\site-packages\pip\req\req_install.py", line 387, in setu
p_py
import setuptools # noqa
File "c:\python27\lib\site-packages\setuptools_init
.py", line 14, in
from setuptools.extension import Extension
File "c:\python27\lib\site-packages\setuptools\extension.py", line 11, in
from . import msvc
File "c:\python27\lib\site-packages\setuptools\msvc.py", line 30, in
import distutils.msvc9compiler as msvc9compiler
File "c:\python27\lib\distutils\msvc9compiler.py", line 257
vcvarsall = os.path.join(productdir, "vcvarsall.bat")
^
IndentationError: unexpected indent

C:\Python27\Scripts>

Any suggestions

I did have earlier problems vcvarsall.bat
Followed Youtube clip https://www.youtube.com/watch?v=s7n0OwL2jE4
and addded the following to mscv9compiler.py

vcvarsall = "c:/Users/Michael/Appdata/Local/Programs/Common/Microsoft/Visual C++ for Python" + "/vcvarsall.bat"

Fixed the vcvarsall indent problem by removing the line I added
vcvarsall = “c:/Users/Michael/Appdata/Local/Programs/Common/Microsoft/Visual C++ for Python” + “/vcvarsall.bat”
Using Debug I get the following after what appears to be a successful compile.

C:\Plone43>c:\plone43\bin\buildout -D
Unused options for buildout: 'buildout-user' 'need-sudo'.
Updating instance.
Updating repozo.
Updating backup.
Updating zopepy.
Updating precompiler.
Compiling Python files.
SyntaxError: ('invalid syntax', ('c:\plone43\eggs\restrictedpython-3.6.0-py2.
6.egg\RestrictedPython\tests\before_and_after27.py', 30, 17, ' x = {y: y f
or y in whatever if y}\n'))

SyntaxError: ('invalid syntax', ('c:\plone43\eggs\restrictedpython-3.6.0-py2.
6.egg\RestrictedPython\tests\security_in_syntax27.py', 6, 13, ' {y: y for
_restricted_name in x}\n'))

Compiling locale files.
Error while compiling c:\plone43\eggs\python_gettext-1.2-py2.6.egg\pythongettext
\tests\test5.po
Error while compiling c:\plone43\eggs\python_gettext-1.2-py2.6.egg\pythongettext
\tests\test_escape.po
Updating run-instance.
Updating service.
*************** PICKED VERSIONS ****************
[versions]

*************** /PICKED VERSIONS ***************

C:\Plone43>

Is there a problem here ?
The error messages you see are generated by the precompiler. It's a piece of code that aims at avoiding that your Plone instance has to compile files on the fly, because in a properly protected installation the code directories are read-only. The downside is that the precompiler sometimes tries to compile files that are not really meant to be compiled. It could be avoided but it happens, and it does not necessarily imply that your installation can't work.
These specific error messages are popping up on the net for ages. Why exactly is a mystery. The test5.po file is obviously wrong, but maybe it is intentional to generate an error in a test suite.

Many thanks gp54321
In reality I am an enduser, and NOT a poweruser

I have a functional 4.3.12 version
BUT wanted to upgrade as they (4.3.xx) became available

The upgrade process "for me" beyond 4.3.12 has been tedious and frustrating to say the least. Because of my lack of programming knowledge, I can only work with what I see.

Any suggestions from you or the Plone Community have been and will be appreciated. TIA

my suggestion is to try to start the new Plone instance and see if it works (bin/instance fg)
The upgrade process for Plone could be better, yes. However the issues that you have so far are more related to a generic python setup on a Windows computer (not a much used platform for Plone these days)

Thx gp54321 ... again I've come to a dead end (bin/instance fg - did not help)

Will hold at 4.3.12 on the windows platform
and begin the "long" learning curve of moving to Linux/Ubuntu

Buggah :o)

Wishing you and the Plone community all the best for 2018

Hi Michael :slight_smile: What method are you using to install Plone 4.3.1 on Windows?

Hi Kim
Best wishes for the New Year
I used the original 4.3.1 windows installer for 64bit

Ooops sent before I finished
https://launchpad.net/plone/4.3/4.3.1/+download/Plone-4.3.1-win64.exe

On another matter I have an appointment to Flinders University to see what Computer undergraduate course might suit me to further my Plone experience
Any suggestions on your part would be appreciated.
Already looking at Linux/Unix/Ubuntu, Python, database structures including faceted navigation - if you have a link to a US style tertiary course, I would appreciate a URL. TIA

We no longer have binary installers like that for Plone on Windows but we do have a new type of installer that works nicely if you're on a newish version of Windows. It installs the Linux subsystem then uses the unified installer. For older versions of Windows, it installs prereqs then runs the "simple buildout" method. https://github.com/plone/WinPloneInstaller/ Mind you, if you need to have those install Plone 4 you will have to modify the innards.

Those classes seem good!