Which good version combination of RelStorage for Plone 5.x

https://stackoverflow.com/questions/47522662/which-good-version-combination-of-relstorage-for-plone-5-x

I tried to install Plone5.1RC1 / RelStorage2.x / psycopg2.7x, but I got an error. then I tried to install Plone5.0x / RelStorage1.6x-2.x / psycopg2.7x, but I got an error. Please let me know, best ...

tagged: plone https://stackoverflow.com/tags/plone, relstorage https://stackoverflow.com/tags/relstorage Nov 28 at 1:47

I'm experiencing a similar issue.

it seems that ZEO = 5.1.1 version pin is giving me problems.

Relstorage < 2.0.0 gives an errror on startup:

  File "/home/flip/plone5/rfasite/eggs/RelStorage-1.6.3-py2.7.egg/relstorage/options.py", line 22, in <module>
    from ZEO.zrpc.connection import Connection as __Connection
ImportError: No module named zrpc.connection

Relstorage 2.1.0 doesn't build:

  [versions] constraint on zeo: 5.1.1
  Requirement of relstorage: ZEO<5.0,>=4.3.1
While:
  Updating instance.
Error: The requirement ('ZEO<5.0,>=4.3.1') is not allowed by your [versions] constraint (5.1.1)

I have a 5.1rc2 site running with relstorage = 2.1a2 and ZODB = 5.1.1 pinned

I'm able to run buildout, but I haven't actually tested relstorage yet

1 Like

oh, and relstorage 2.1.0 is out now

1 Like

I've been using 2.1.0

For lol's, I'm building with 2.1a2 now to see what's up.

ZEO 5.1.1 ZODB was a typo yes?

Ah! I think it's my python version:

And my error is:

Error: The requirement ('ZEO<5.0,>=4.3.1') is not allowed by your [versions] constraint (5.1.1)

I'm going to pull on this thread and see what happens.

With a python 2.7.13 I have a different error.

But can confirm that relstorage doesn't complain. ¯\_(ツ)_/¯

Plone Foundation Code of Conduct