Where is products directory


i'm trying to install a plone modul login lockout

Plone 5.2.2 (5209)
CMF 2.4.8
Zope 4.5.1
Python 3.6.8 (default, Apr 2 2020, 13:34:55) [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]
PIL 6.2.2 (Pillow)
WSGI : Activé
Serveur : waitress 1.4.4

i tried to install it with buildout, but it installs the 2015 version 0.4 from pypi

and manually i push the directory LoginLockout in products

"Place the Product directory 'LoginLockout' in your 'Products/' directory. Restart Zope."

and it doesn't work, i tried with Products, same it doesn't work.

So how to install this modul manually.

Thank you

That is quite an obsolete way to install it.

Probably a new version of the package should be released.

I would open a couple of issues to the repository to kindly ask:

  1. for instructions to be updated
  2. for a new release

While waiting for a release you can use, mr.developer and checkout the repository.

I hope that was clear enough :smiley:, it might not be easy if you are totally new about Plone development.

Thank you,

I had tried with mr developer. Like it had led to nothing. I see that the git tree is fetched under src. But in the plone config I don't see any new modules.


buildout.sanitycheck makes sure you're not running buildout

as root.

extensions =

auto-checkout = monPackage

monPackage = git *github/collective/Products.LoginLockout.git

ls src/monPackage/
base.cfg bootstrap.sh checkouts.cfg docs Products README.rst setup.py test-4.3.x.cfg test-5.1.x.cfg test-6.0.x.cfg
bootstrap.py buildout.cfg code-analysis.cfg MANIFEST.in Products.LoginLockout.egg-info setup.cfg test-4.1.x.cfg test-5.0.x.cfg test-5.2.x.cfg versions-2.7.cfg

Try with this configuration:

[quote="Gero, post:3, topic:17550"]

extensions =

auto-checkout = Products.LoginLockout

eggs +=

Products.LoginLockout = git https://github.com/collective/Products.LoginLockout.git

Then try:

./bin/develop co Products.LoginLockout
./bin/develop rb

Good luck!

1 Like

it works perfectly. thanks.

1 Like