When comments are activated, they become required

this applies to Plone 6.05 and 6.07 Classic.

when comments are allowed, the comment box displays properly at bottom of the page. however, the comment shows a red dot and is required to save a page.
i know this is not how it has been. Has anyone else seen this?

Not sure how it was, but it makes sense to me that the textarea is required if you want to post a comment.

I think there is a 'mix up here'. It is not possible to click the 'cancel' button without any text (present). The best solution (in my opinion) would be if the cancel button did not appear until the Comment (text) field had any input.

(sorry, in previous version it was all bold - looked like i was shouting )
please note that comments are required (red dot) this should not be that way. also, it never has been. this is a bug as far as i can tell.
also, in plone 6 classic (any sub version) create a page, then press cancel (that is, you don't want to finish creating) you will find you must enter something into the "title" box before you can cancel the creation of the page.
again, never was this way before.

Note: i was adding a content rule and the same behavior occurred. when creating rule, i added a "condition' (user role). took me to a page to select user role from list. as with above, i could not cancel out (as if i made a mistake adding this condition) unless i chose a role and then 'cancelled'

I just tried the comment form in an old Plone 4.3 here and there its also required.

Regarding the cancel button: this got fixed here: `pat-validation` disables "Cancel" Button on validation error · Issue #1259 · plone/mockup · GitHub ... you can update to Plone 6.0.6 or only the latest plone.staticresources = 2.1.13 too ...

1 Like

Thanks I’ll give that a try and update the community

hi, the update fixed the problem - thanks a lot.
I say it fixed it that standard plone CT (page) works perfectly. and content created via a dexterity content type i created on the updated site, also worked perfectly
however, content created via a content type created in older version of P6 does not get changed. how to i fix the content type from older P6 so that it works properly?

Thanks for your help

Maybe related, but when using a custom AddForm, the problem seems to 'still be there'.

    from plone.dexterity.browser.add import DefaultAddView
    from plone.dexterity.browser.add import DefaultAddForm

class MyItemAddForm(DefaultAddForm):
    portal_type = "my_type"
    default_fieldset_label = 'Home'

    def __init__(self, context, request):
        super(MyItemAddForm, self).__init__(context, request)

    def updateWidgets(self):
        super(MyItemAddForm, self).updateWidgets()
        self.widgets['placeholder'].mode = interfaces.HIDDEN_MODE 
    def updateFields(self):
        super(MyItemAddForm, self).updateFields()

Can anyone confirm? (so I know it is not something with the content type)