Volto - Unable to Login to Plone 6.0a4

I created a fresh Volto add-on using yo @plone/volto. I created this in a subdirectory of a git clone of the Volto repository. Than I run yarn start in this subdirectory and specified a HOST and a PORT (e.g. localhost and port 3000).
I created and run also a Plone backend from the coredev buildout (master) and run that with instance fg on localhost:8080.
It was not possible to login to the Plone instance via Volto frontend. It works fine using the classic frontend.
The error message from Volto points to case sensitive login. But there is no issue with caps lock on my keyboard.

I researched further and found out that the issue with the login came from the collective.honeypot Plone add-on. The login works again after a switch back to the use of collective.hcaptcha.
The add-on collective.honeypot isn't Plone 6 / Volto ready yet.

Today I got after an git pull and the run of buildout again the issue with the login from Volto. I get the following Traceback in the shell:

Traceback (innermost last):
Module ZPublisher.WSGIPublisher, line 167, in transaction_pubevents
Module ZPublisher.WSGIPublisher, line 376, in publish_module
Module ZPublisher.WSGIPublisher, line 271, in publish
Module ZPublisher.mapply, line 85, in mapply
Module ZPublisher.WSGIPublisher, line 68, in call_object
Module plone.rest.service, line 22, in call
Module plone.restapi.services, line 19, in render
Module plone.restapi.services.auth.login, line 80, in reply
Module plone.restapi.pas.plugin, line 197, in create_token
AttributeError: 'str' object has no attribute 'decode

I use Volto 15.8.1 and:
Plone 6.0.0a4 (6004)
CMF 2.5.4
Zope 5.5.1
Python 3.9.12 (main, Mar 26 2022, 22:43:49) [GCC]
PIL 9.1.0 (Pillow)
WSGI: On
Server: waitress 2.1.1

Do I need to upgrade to Volto 15.9.0 or is there a fix for the Plone restapi which solved this error?

You'll need to use a plone.restapi checkout as that problem is fixed, but not released just yet.
You can grab it from GitHub - plone/plone.restapi: RESTful API for Plone..

If you happen to use GitHub - plone/buildout.coredev: Plone Core Development Buildout, it's checkout should already be included.

I use the git clone from buildout.coredev branch master. The plone.restapi lives in the src folder. I went to this folder and made an explicit git pull, but there was no change in the behavior of Volto. The login didn't work further.
The plone.restapi is version 8.22.0 according to the Plone add-on control panel.

I researched further and it seemed running my development.cfg, which extended buildout.cfg caused the issues. I did a work around with additions to the buildout scripts from coredev (not a stable solution, because of issues with further git pull actions).
It's possible yet to run buildout, get my Plone add-on cloned and install it as well as login from the Volto frontend.

Plone Foundation Code of Conduct