Versioning in Plone 5.1.5 [SOLVED]

In a Plone 5.1.5 site, (upgraded from Plone 5.0.6 once), I just noticed versioning is not working properly. Making a new Plone site on the same Zope gives same result.

Steps to reproduce:

  1. Install a new site, add a Page, edit it, save: versioning works.

  2. Add a new Dexterity Content type TTW (MyType), add rich text behavior and versioning behavior

  3. Add 'MyType', edit it, save it

  4. /@@historyview shows no edits (it only shows 'State change (publish etc')

  5. I installed collective.revisionmanager and it only shows histories for 'Pages'

  6. Looking in /portal_types I see both content types have

    plone.app.versioningbehavior.behaviors.IVersionable

  7. A new Plone 5.1.5 setup has the same (mis)behaviour: https://www.youtube.com/watch?v=Ex7INkuOg74&feature=youtu.be

I hit the same issue. You can work around it by going to the portal_diff tool in the ZMI and add your content type there.

Thanks a lot.

For reference: Versioning works in Plone 5.0.6 without any (extra) entry in port_diff tool (in other words: versioning worked before the site was upgraded to 5.1.5.

Update: I checked Plone 5.2 and it is the same (not working). If this is expected behavior: maybe we should change the description of 'versioning behavior to something like: Versioning support with CMFEditions. You also need to add your portal type to /portal_diff tool in the ZMI' ?

Actually, I discovered that history view only shows old versions version for old content.

Can you confirm that (also) new content has working versioning / history

It turns out that migration did not keep the settings in /@@content-controlpanel (versioning settings), so only old content did have these settings.

In other words:

  1. Check that versioning behavior is turned on in dexterity control panel
  2. Check the it is enabled in /@@content-controlpanel

Plone Foundation Code of Conduct