ValueError: Too many values to unpack in plone.recipe.zeoserver == 2.0.1

I am attempting to upgrade from Plone 5.0.10 to 5.1-latest. I have been working through some issues with buildout, but this one has me hung up a bit.

I am using https://dist.plone.org/release/5.1-latest/versions.cfg, which pins plone.recipe.zeoserver at 2.0.1. buildout reports the following error:

An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1942, in main
    getattr(buildout, command)(args)
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 506, in install
    [self[part]['recipe'] for part in install_parts]
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1094, in __getitem__
    options._initialize()
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1198, in _initialize
    self.initialize()
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1204, in initialize
    recipe_class = _install_and_load(reqs, 'zc.buildout', entry, buildout)
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1158, in _install_and_load
    allow_hosts=buildout._allow_hosts
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 812, in install
    return installer.install(specs, working_set)
  File "/usr/local/bin/Plone/zinstance/env/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 643, in install
    [requirement] = err.args
ValueError: too many values to unpack

I have updated zc.buildout to the latest 2.13.2, but I am still encountering the error.

I also have already read through this post: Rebuilding a Plone 4.2 site and getting ValueError: too many values to unpack.

It does not seem to be the same issue that I am experiencing. Any help is appreciated if anyone has encountered this before.

Thank you!

The problem was actually with setuptools and zc.buildout versions. See: Upgrade from Plone 5.0.10 to 5.1-latest BTree 4.4.1

Plone Foundation Code of Conduct