ValueError: need more than 0 values to unpack Ploneintranet

I am trying to install Ploneintranet from this repository following the Ploneintranet quickstart guide on Debian 9 with Python 2.7.

Then when I run the command make buildout, I have the following error:

An error occurred when trying to install /home/leonardo/.buildout/downloads/dist/Products.CMFPlone-5.0.8.tar.gz. Look above this message for any errors that were output by easy_install.
While:
  Installing instance.
  Getting distribution for 'Products.CMFPlone==5.0.8'.

An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 2123, in main
    getattr(buildout, command)(args)
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 796, in install
    installed_files = self[part]._call(recipe.install)
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/buildout.py", line 1553, in _call
    return f()
  File "/home/leonardo/.buildout/eggs/cp27mu/plone.recipe.zope2instance-4.2.22-py2.7.egg/plone/recipe/zope2instance/__init__.py", line 113, in install
    installed.extend(self.install_scripts())
  File "/home/leonardo/.buildout/eggs/cp27mu/plone.recipe.zope2instance-4.2.22-py2.7.egg/plone/recipe/zope2instance/__init__.py", line 617, in install_scripts
    requirements, ws = self.egg.working_set(['plone.recipe.zope2instance'])
  File "/home/leonardo/.buildout/eggs/cp27mu/zc.recipe.egg-2.0.3-py2.7.egg/zc/recipe/egg/egg.py", line 84, in working_set
    allow_hosts=self.allow_hosts)
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 913, in install
    return installer.install(specs, working_set)
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 714, in install
    for dist in self._get_dist(req, ws):
  File "/home/leonardo/.buildout/eggs/cp27mu/plone.versioncheck-1.2.1-py2.7.egg/plone/versioncheck/tracking.py", line 22, in get_dist
    dists = old_get_dist(self, requirement, *ags, **kw)
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 563, in _get_dist
    dists = [_move_to_eggs_dir_and_compile(dist, self._dest)]
  File "/home/leonardo/proyectos/plone/quaive/ploneintranet-deploy/local/lib/python2.7/site-packages/zc/buildout/easy_install.py", line 1699, in _move_to_eggs_dir_and_compile
    [tmp_loc] = glob.glob(os.path.join(tmp_dest, '*'))
ValueError: need more than 0 values to unpack

Any idea how to fix this error?

Looks like a setuptools / zc.buildout issue. Try to use different versions...

2 posts were split to a new topic: Unable to start my zope server

Currently the version pins for that buildout are:

setuptools = 36.3.0
zc.buildout = 2.9.4

I made a branch with updated versions for these packages:

@macagua would you mind to test if this fixes your issue and report back?
In case of problems let me know!

Hi @tisto

You are right, as PloneIntranet is Plone 5.0.8 based, I checked the buildout configuration of Plone-5.0.8-UnifiedInstaller-r1.tgz then replace the versions like these:

$ git diff buildout.d/versions.cfg requirements.txt
diff --git a/buildout.d/versions.cfg b/buildout.d/versions.cfg
index ac930b2..c6e5512 100644
--- a/buildout.d/versions.cfg
+++ b/buildout.d/versions.cfg
@@ -15,8 +15,10 @@ selenium = 2.53.6
 
 # NOTE: setuptools and zc.buildout versions must be in sync with:
 # ../requirements.txt
-setuptools = 36.3.0
-zc.buildout = 2.9.4
+# setuptools = 36.3.0
+# zc.buildout = 2.9.4
+setuptools = 26.1.1
+zc.buildout = 2.5.3
 
 # the new plone.testing that throws a fit on test-isolation leakage
 plone.testing = 5.0.0
diff --git a/requirements.txt b/requirements.txt
index a79cb58..d9f0d64 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,4 +1,6 @@
 # NOTE: setuptools and zc.buildout versions must be in sync with:
 # ./buildout.d/versions.cfg
-setuptools==36.3.0
-zc.buildout==2.9.4
+# setuptools==36.3.0
+# zc.buildout==2.9.4
+setuptools==26.1.1
+zc.buildout==2.5.3

With these changes my PloneIntranet buildout is working and complete!

Thank you @tisto

Hi @alert

Yes, let me check this branch, test it and report back to you!

1 Like

@alert the update-buildouts branch working very good! Thanks you!

1 Like

"fun fact":
Trying to run buildout (vanilla plone coredev 5.2 and 6.0) on a newly setup computer I run into the same error message. The issue but was : persistent/_compat.h:18:10: fatal error: Python.h: No such file or directory
#include "Python.h"

sudo apt-get install python3.7-dev ... fixed the problem

Maybe that's related to

PS ups, updated the link

exactly the same error message at the end of the stack but only some headerfiles were missing. :rofl:

I got this error simply from a bad (i.e. indented) comment in my buildout.cfg, for example:

 eggs +=
      # basis of virus-scanning
      collective.clamav

rather than

 # basis of virus-scanning
 eggs +=
      collective.clamav

Also working:

 eggs +=
 # basis of virus-scanning
      collective.clamav

Plone Foundation Code of Conduct