Using WebDAV or FTP in Plone 5

Hi I'm using Pone 5 and I've been trying to use WebDAV and FTP without any luck. According to the documentation, WebDAV is enabled by default in Plone. A Plone server listening on port 8080 will also accept WebDAV traffic on that port.However, any attempts to connect to that port have failed. I've also tried placing the following in my buildout.cfg

recipe = plone.recipe.zope2instance

Running bin/instance fg shows:

2015-11-03 21:49:08 INFO ZServer HTTP server started at Tue Nov  3 21:49:08 2015
    Port: 8080
2015-11-03 21:49:08 INFO ZServer WebDAV server started at Tue Nov  3 21:49:08 2015
    Port: 1980
2015-11-03 21:49:14 INFO Plone OpenID system packages not installed, OpenID support not available
2015-11-03 21:49:16 INFO Zope Ready to handle requests

But even though the Plone site comes up, I can't connect to it otherwise. I've been mainly trying with both AnyClient and Cyberduck as well as the built in Windows WebDAV and nothing works.

Do you get any error logs from either the server or the client?
Have you used the cadaver client which seems to be the most compatible in my experience.

Your webdav server is listening on port 1980 on all IP addresses. If you can not connect then you have a network or firewall problem - outside the scope of Plone.


I was thinking the same thing. I have run into firewalls and proxies that block that port. It's fairly common.

To confirm that is the issue, I think you could set your http-address to 1980 (and comment out your WebDAV settings for now) in then just try browsing to your Plone site on 1980.

If you cannot browse to it, then the port is being blocked somewhere.


1 Like

Thanks for the replies. I tried the suggestions and It turned out to be indeed the firewall blocking the port.