Using OpenID with Plone and a third party Identity Server

Hello

I am new plone and have been going through the plone documentations. I am building a POC with Plone 5.2 and a third party Identity & management Server (WSO2 IAM). I have come across several plugins for plone but settled with OpenID and pas.plugin.authomatic. I have problems using this plugin (maybe because i am a novice). How can I enable pas.plugin.authomatic within Plone 5.2? I understand how it should be listed in the buildout.cfg file. But I don't know how to include the dependencies. I get an error "Cookie module not found". Furthermore, I noticed that the build for the pas.plugin.authomatic is failing, this shouldn't be a problem, due to a updated branch right? I appreciate for any help given...

Thank you

Very much

Parami De Silva

I wrote pas.plugin.authomatic but had no time (nor someone paid me) to update it.
If you provide the full error/traceback I may give you some hint.

The broken build is because of a version conflict for pyflakes.

Getting distribution for 'lxml==4.4.2'.
Got lxml 4.4.2.
Getting distribution for 'flake8>=2.4.0'.
Got flake8 3.7.9.
Getting distribution for 'check-manifest'.
Got check-manifest 0.40.
Version and requirements information containing pyflakes:
  [versions] constraint on pyflakes: 1.5.0
  Requirement of flake8>=2.4.0: pyflakes<2.2.0,>=2.1.0
While:
  Installing.
  Getting section code-analysis.
  Initializing section code-analysis.
  Installing recipe plone.recipe.codeanalysis.
Error: The requirement ('pyflakes<2.2.0,>=2.1.0') is not allowed by your [versions] constraint (1.5.0)
The command "bin/buildout -N -t 3 code-analysis:return-status-codes=True" failed and exited with 1 during .

I always struggle a bit reading the buildout errors.

So, I tried a bit harder :slight_smile:

FWIW, the Python 3 test fails because of...

test_plone52.cfg hardcodes pyflakes 1.5.0

but flake8 on the other hand requires a pyflakes version between 2.1.0 and 2.2.0

This causes a version conflict.

So, the package is not necessarily broken, but the test setup.

P.S.: Actually, there is one question unanswered...

Getting distribution for 'flake8>=2.4.0'.

Where is this coming from?

Hello Jens

I managed to find the solution...Buildout should be configured for python 2.7.. A python file imports a python library Cookie, but in Python 3 the library has been renamed to http.cookie. Hence the error... Suggest to make the library compatible for python 3...I can give a try with some help...

Thank you

Best regards

Parami

Hello,
pas.plugin.authomatic is compatible with python 3, but only on source code, it's not yet released.
You can use it as "source" package with mr.developer

Ok ...I will give it a spin and see.

Thanks

If someone could fix the TravisCI test setup on master I am happy to cut a release.

Plone Foundation Code of Conduct