Use Plone with Sentry "problem"

Hi everybody,

i installed my own Sentry Server (it works) and Plone (works to). Now i want to start tracking Errors with Sentry und so i pasted this Code in the plone buildout.cfg:
recipe = plone.recipe.zope2instance
event-log-custom =
%import raven.contrib.zope

path ${buildout:directory}/var/instance.log
level INFO

level ERROR

But i get an Error raven.contrib.zope can’t be found. Does anybody have the same Problem ?
Sorry for my bad english.

Many thanks in advance


Don't forget to add raven to your buildout:

hi jaroel,

i already added raven to the buildout.cfg but i get this Error Message:

Could you check your find-links ? :thinking: maybe you are restricting it to a few servers and pypi is not there?

I wrote this a while ago... could help?

gforcada i checked find-links an evereythings seems right.
tkimnguyen : I tried to use your instruction but i had used Non-Zeo Plone. I edited only the buildout.cfg. Should i edit the base.cfg too ?

I found something. I have 2 Users johannes and sentry. I have installed Plone on the profile of johannes and Sentry on the profile of sentry. Could this be the reason why raven can't be found ? Because the library is on the profile sentry?

that can be also happening, but the screenshot you shared earlier was telling that your buildout was not able to find the python package raven... is that solved? Without that, that sentry is installed here or there does not matter as long as you don't have the library that allows you to connect to sentry :sweat_smile:

finally after hours of work i found the Problem :sweat_smile: the Versio Plone-5.0.4 was buggy. After i had Installed the Version 5.1.2 everything was working. Thank you all for your help.
Now i want to track Unauthorized Access. At example if an user types wrong access data. Where do i have to change the config, so that an Unauthorized Access is written in the instance log as an Error. So that Sentry can read it out.

Look for Errors on Site Setup. There remove Unauthorized from the "Ignored
exception types" list.

1 Like

Hi Mike,

thank you for your advice. I have removed Unauthorized from the "Ignored
exception types" list. But it don't shows me any error. Not at Sentry nor in my admin account. I logged out and tried
to log in with wrong access data. After i log me in again there isn't any error log entry nor in the linstance.log nor at Sentry.
Have i to activate a caching function ?

I think Unauthorized is only logged when you don't have access to a specific resource, not when a login failed.

Maybe you want to give ftw.raven a try - we use it sometimes for our bigger sites. and it works like a charm!

We (4teamwork AG) have used ftw.raven in production for years. We're currently testing it against both 4.3 and 5.1 (as with all of our packages, refer to the test-*.cfg files at the project root to quickly determine what we test a package against) - it should 'just work', if following the documentation.

But, as our documentation states, Be aware that there is already a standard logging based Zope / Plone integration for raven. You should use the standard implementation unless you want the exception hook based integration. - - are you actually sure this is what you want to do instead of just using the basic out of the box log parsing integration Sentry already offers?

New sentry integration with Plone 5: