Unable to upload files and folders to Plone 5.2.4

Hello,
Despite my best efforts, I cannot transfer files and / or folders from my local computer to Plone 5.2.4.

Indeed, the transfer is going well to Zope.

But when you try to transfer to Plone you get an error message:
"404 Not Found".
Anyone have any idea how to fix or work around this problem?

Thank you in advance for your invaluable help.

"404 Not Found" means that some URL component could not be resolved. Thus, you should look at the URL (sometimes missing permissions are mapped to "Not Found" as well). Especially, you should compare the URLs for "transfer to Zope" and "transfer to Plone" (I do not understand those terms).

Hello,
Thank you very much @Dieter.

I will make the necessary checks.

How do you 'transfer' them ?

I use a WebDAV client mainly WinSCP and incidentally, CyberDuck, RaiDrive, etc.

This is major information. For WebDAV access, you must typically use the so called "WebDAV source port". While WebDAV works over HTTP, it requires different handling compared to "normal" browser access. E.g. browser access would typically use cookie based authentication while WebDAV use HTTP authentication, and browser access likely includes navigation around the main content while WebDAV access wants the raw content. Using a special port for WebDAV access allows to distinguish the two access types.

Thank you for this valuable information.
Thank you all for putting me on the right path.
I will configure the source port.

could this be of any help: Webdav configuration Plone 5.2.3(rc1) - #11 by Adomy

Hello,
I try to make the configuration of WebDAV for Plone 5.2.4.
I'm trying from @dieter and @espenmn advice.

In the Buildout.cfg file, I put this:
"[instance]
<= instance_base
Recipe = plone.recipe.zope2instance
HTTP-Address = 8090 9890
HTTP-FAST-LISTEN = TRUE
WSGI = ON
WebDAV-Address = 9890
WSGI-OPTIONS =
WebDAV-Address 9890
Zope-Conf-Additional =
Webdav-Source-Port 9890
HTTP-REALM WELCOME "

Then in PowerShell:
.................................................. ..
.................................................. ...
........................
PS C: "PS C: > CD Users
PS C: \ Users> CD username
PS C: \ Users \ Username> CD Plone

PS C: \ Users \ Username \ Plone>. \ Py-3.8.6.final.0 \ Scripts \ Buildout.exe

\ Users \ Username \ Plone>. \ Py-3.8.6.final.0 \ Scripts \ Buildout.exe
PS C: \ Users \ Username \ Plone>. \ Py-3.8.6.final.0 \ Scripts \ Buildout.exe
While:
Initializing.
Error: Coudn't Open C: \ Users \ Username \ Plone \ Buildout.cfg
PS C: \ Users \ username \ Plone> "

Someone has an idea of ​​the origin and meaning of this error message?
Thanks in advance.

I do not use Windows, but is it possible that the file (you just edited) buildout.cfg is NOT in the folder c:\Users\Username\Plone\ but in the folder c:\Users\Username\Plone\zinstance\ ? (or \zeoserver ). If that is not the case, maybe you need to change the permissions

Hello,
In fact the "buildout.cfg file is in the folder
"c: \ Users \ Username \ Plone \ zinstance ".
On the other hand, the executable "buildout.exe" is in the folder
"C: \ Users \ Username \ Plone \ py-3.8.9.final.0 \ Scripts"

Hello,
I am trying to configure WebDAV for Plone 5.2.4.
In the buidout file I added this:

"[instance]
<= base_instance
recipe = plone.recipe.zope2instance
http-address = 127.0.0.1:9090 127.0.0.1:8080
http-fast-listen = true
wsgi = on
zope-conf-additional =
webdav-source-port 9090
http-realm Welcome "
Then after running buildout, see the following results:

  1. Ouput file: wsgi.ini
    [server: main]
    use = egg: waitress # main
    listen = 127.0.0.1:9090 127.0.0.1:8080
    threads = 4
    clear_untrusted_proxy_headers = false
    max_request_body_size = 1073741824

  2. Ouput file: zope.conf
    % define INSTANCEHOME ...
    ...
    <zodb_db>
    ...
    </zodb_db>
    python-check-interval 1000
    webdav-source-port 9090
    http-realm Welcome

A priori everything went well.
However when I try to transfer files from my local computer to plone to a folder (directory) in plone,
I have a prompt which asks me for a password corresponding to the user (manager) connected.
When I enter the password,
I have the "404 not found" error.

Anyone have any idea where the problem is?

Thanks in advance.

How do you try to transfer the files ?

Do you use the WebDAV source port for your WebDAV access?

I'm just trying to transfer a few htm files.
WinSCP offers several tools. I select WebDAV.
The window on the left allows me to access files and folders locally on my computer.
The window on the left is connected to plone which in this case is installed on the same computer.
This is why I am using the IP 127.0.0.1.

Absolutely, I am using WebDAV source 9090 as it is defined.

Could you try with Cyberduck ? (it works for me)

Thanks for the suggestion.
I had already tried with cyberduck, but the result was no better. I have tried other WebDAV clients, to no avail.
I wonder where it blocks ....

Plone Foundation Code of Conduct