Ugrade 4.3.15 -> 5.0.7 seems ok but cannot upgrade site within browser

Hello

After upgrading an old Plone-Site from 4.1.x all the way over 4.2.x to 4.3.15 I want to do the latest step to version 5.0.7.

I can do buildout - and in my view it does not look so bad - and after do plonectl start I can access the site via localhost:8080 but then it's getting weird:

I click on Upgrade, enter the credentials and then I get an error-page in the browser :frowning:

Site Error

An error was encountered while publishing this resource.

Sorry, a site error occurred.

Traceback (innermost last):

Module ZPublisher.Publish, line 249, in publish_module_standard
Module ZPublisher.Publish, line 197, in publish
Module zope.event, line 31, in notify
Module zope.component.event, line 24, in dispatch
Module zope.component._api, line 136, in subscribers
Module zope.component.registry, line 321, in subscribers
Module ZODB.Connection, line 860, in setstate
Module ZODB.Connection, line 914, in _setstate
Module ZODB.serialize, line 613, in setGhostState
Module zope.component.persistentregistry, line 40, in __setstate__
Module zope.interface.adapter, line 91, in _createLookup
Module zope.interface.adapter, line 439, in __init__
Module zope.interface.adapter, line 476, in init_extendors
Module zope.interface.adapter, line 480, in add_extendor

AttributeError: type object 'IFieldValueSetter' has no attribute 'iro'

Troubleshooting Suggestions

The URL may be incorrect.
The parameters passed to this resource may be incorrect.
A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error log.

If the error persists please contact the site maintainer. Thank you for your patience.

After this I cannot enter the main url anymore - I get the error

Site Error

An error was encountered while publishing this resource.

Sorry, a site error occurred.

Traceback (innermost last):

Module ZPublisher.Publish, line 247, in publish_module_standard
Module zope.publisher.skinnable, line 47, in setDefaultSkin
Module ZODB.Connection, line 857, in setstate

ConnectionStateError: Shouldn't load state for 0x0651 when the connection is closed

Troubleshooting Suggestions

The URL may be incorrect.
The parameters passed to this resource may be incorrect.
A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error log.

If the error persists please contact the site maintainer. Thank you for your patience.

To me, that is very strange. From what I have read in the documentation I have removed my subskins theme and disabled the add-on before doing upgrade to 5 - but still no success... I tried several times an upgrade to several versions of Plone: Always with the same sympthom...

At pastebin you can find the latest error messages from /work/plone/zinstance/var/log/instance.log:
https://pastebin.com/keCjQUEe

Due to one error I've seen I searched and looked into the topic Cleaning up a wicked mess but i didn't get, what I could do at what place in what state: quite lost at this stage...

Would be nice getting a hint, how to proceed - thank you very much!

Kind regards
David

Hello

Just now I was checking again regarding the upgrade.
On the Upgrade-guide https://docs.plone.org/manage/upgrading/version_specific_migration/p4x_to_p5x_upgrade.html I read in the first line:

  • Before you upgrade read ../into.rst and ../preparations.rst.

To be honest, I didn't read through this file before I tried (and opened this case) but I also didn't find them.
BUT: Where do I find those files? I cannot find it on the community, on the plone-site, on Google and also not anywhere on my LIINUX-machine - is it below the plone root-directory or within the UnifiedInstaller directory :frowning:

Thank you for helping me with this and kind regards
David

intro.rst == https://docs.plone.org/manage/upgrading/intro.html
and
preparations.rst == https://docs.plone.org/manage/upgrading/preparations.html

This seems to be a bug in the docs.

Hi Thomas

Ok, I am working through those documents - even I have checked some of its content before (after knowing what those files are, I also know, that I worked through them already partially).

I get stuck now with the following out of the documentation Preparations:

  • Make sure all the add-on products you are using have updated to support the version of Plone you are upgrading to.
  • Start with the third-party products that are in use on your site.
    • Verify that they have been updated or verified to work on the new version, and get them upgraded in your existing instance before you start the Plone/Zope/Python upgrade if possible.

Also not so clear from this point of view: https://docs.plone.org/manage/upgrading/addon_upgrade.html... My [Versions] section of buildout.cfg looks as following:

[versions]
ZopeSkel = 2.21.2
plone.recipe.unifiedinstaller = 4.1
lxml = 2.3.6
Cheetah = 2.2.1
Pillow = 1.7.8
Products.DocFinderTab = 1.0.5
collective.recipe.backup = 2.9
plone.recipe.command = 1.1
zc.buildout =
setuptools =

I assume in the meantime, that I will have to change lxml to 3.5.0, Pillow to 3.3.0, I would change UnifiedInstaller also to version 5.0.7 (Or can I even remove this entry, as I update and therefore do not use the UnifiedInstaller within this instance anymore)... But how do I properly find out, what versions are needed by Plone 5.0.7 (Haven't found a note for Cheetah, ZopeSkel, Products.DocFinderTab and others)?

What are ThirdParty products, and what not? Are any of these considerd to be ThirdParty-products? Or is the (also installed) PloneLDAP based on LDAPMultiPlugins/LDAPUserFolder (I had to copy it into the folder /plone/zinstance/products) such a Third-Party Add-On?

If you need to know more from my side, I am more than happy to gice more information!

Thank you in advance for any help, appreciate it very much!

Kind regards
David

Did you try re-adding wicked to your buildout? https://pypi.python.org/pypi/wicked
I remembr having migrated one project to Plpone 5 recently and I simply needed to add wicked as a egg.

This is fixed in: https://github.com/plone/documentation/pull/914 and also already fixed in https://github.com/plone/documentation/pull/913

Thanks for reporting !

1 Like

Hi Philip

Thank you for your input. Will I add the wicked-egg before or after the upgrade? And if I want to add it to buildout.cfg, how will I do it?
Just:

eggs =
    ...
    wicked

Afterwords run bin/buildout, right?

Thank you for your help and kind regards
David

Did You manage to solve this problem? I'm struggling with the same error message?

Hi Jelena

"We" could solve the problem. We means @pbauer, who kindly did the migration for us.
The whole process is described in the following post:

Basically the wicked-thing could be solved by the following high-level process:

  • Under Plone 4.x disable wiki behaviour via Control panel
    -> As a result, the wiki-links in the site were not rendered as links anymore but instead just regular text with the double-brackets
  • Add wicked to buildout for Plone 5.x
  • Update to Plone 5.x
  • Add add-on collective.simplewiki to Plone 5 and enable it

More details are in the other post. But I do not really understand the details of what pbauer has done in details :wink:

I hope, this helps you a bit further! Good luck and kind regards
David

Thank you very much for your reply, sorry I have stupid questions so I'll repeat I am new to this. I disabled wiki behaviour in Control Panel and saved changes. But I dont know how to add wicked to buildout for Plone 5, buildout.cfg is very short and I can't find location on where to add wicked. Installed wicked via pip but ... what now?

Hi Jelena

As I mentioned above: Look in buildout.cfg for a section "eggs=". If there is anything just under this, add wicked - if not add wicked as first entry... According my example

eggs =
    ...
    wicked

Afterwards run buildout. Maybe work also through the following topic regarding how to use buildout: it might give you some help as well:


-> Instead of the part with [version] for you in this situation its most probably the thing above with the eggs =...

Hope, you find a way to continue...

Kind regards
David

you're not doing stupid questions at all, just read carefully the answers given to you and follow step by step the instructions provided by @d.wiedemann.

don't do things like installing wicked via pip even as it may sound like the right thing to do in other Python environments; in the Plone world we install things always using Buildout.

come back here with specific questions in case you need further help.

Plone is quite complex, but cool.

Hello again, l was busy with some other project and today I got back to struggle with Plone. Yes I added wicked in eggs section but in release.cfg, since in buildout all I have is
extends=testing.cfg which has extends=rlease.cfg and that file has eggs section
eggs =
${instance:eggs}
Products.PDBDebugMode
wicked
.and installation seems to work, but when I copy data.fs from plone 4.3.1 site and try to upgrade or even open site within zope management interface I get same error:
...AttributeError: type object 'IFieldValueSetter' has no attribute 'iro'
:disappointed_relieved:

So I understand that right:
You have your existing Plone-Site in an older version (which?).
In order to do the upgrade, you want to install a new site with the newer version 4.3.1, copy the content from the old site to the new one and then do the content-upgrade on that new site?

Thank you for clarifying this...

Kind regards
David

I had site in 3.3.0 version and upgraded it to 4.3.1. Now the site is in in 4.3.1 version and I want to upgrade it to version 5. Builtout for windows which I downloaded and installed is in 5.0.8. Now I want to transfer content from 4.3.1 to 5.0.8. And in that step I have problem with "wicked". I supposed copying data.fs to Plone 5.0 and upgrade on site is sufficient but I'm stuck with this error.

Ok, so I would suggest the following:
First update your existing Plone-installation to the latest version of 4 (for me it was 4.3.15)
After that, you upgrade to version 5.
-> Acording to the Plone-Documentation, you should anyway upgrade from latest 4.x to latest of 5...

But that was then the situation, when I needed help from somebody, who is not just a user as I am :wink:

Yes, I found that in documentation and tried upgrade with modifying buildout.cfg to point to the latest version of Plone within 4.3.x "https://docs.plone.org/4/en/manage/upgrading/plone4_minor_upgrade.html" but all I got is :
"IOError: [Errno 13] Permission denied: 'C:\Plone43\#'"
And when I try to install via vagrant, on command vagrant up nothing happens, command prompt just halts. But since i had no much problems from 3.3.0 to 4.3.1 I figured maybe for my site is not so much important being on latest versio...

From a pure Windows point of view regarding Windows permissions, I only can tell you, what you might know already:
What user wants to do the update: Does that user have sufficient permissions? That could be another person than the one you run Plone usually with, therefore the access rights might not be good enough...

But otherwise at this point I have to step back, as i have no clue of Plone on Windows.

Thank you anyway!