TinyMCE indent/outdent don't work in Plone 5.2

Tested on http://demo.plone.org/. It looks like these are setting a padding-left value which is stripped on save. Anyway to configure these to be usable?

I already submitted an issue in CMFPlone for the similar strikethrough problem https://github.com/plone/Products.CMFPlone/issues/3069. I don't know if there was a significant change in TinyMCE versions from 5.1 to 5.2 or if it was the relevant Plone framework that changed, but these were definitely working in previous versions.

This seems to be because of Plone's HTML filtering. If I disable that, I am able to indent. Obviously that is too strong so I tried re-enabling and adding both "padding" and "padding-left" as custom attributes in @@filter-controlpanel. This does not seem to work as expected as those are still stripped.

edit: This is not actually part of the safe_html transform per se, it's part of the tinymce pattern in CMFPlone which also uses the same settings for some things.

I'm dumb, the custom_attributes setting should include "style" not "padding-left". So that works as expected after all.

However, there is still the issue that the default config for tinymce in 5.2 strips the "style" attribute but some of the default toolbar buttons use that. Should this be made an allowed attribute?

The current state of TinyMCE and its default configuration is a mess. We're shipping a mess to content editors. Even simplest editor functionality like left|right|center|justify from the toolbar is not working (in terms of being saved).

... will try to work on some fixes to make at least the default configuration shipped with TinyMCE in Plone 5.2 working. The current state of TinyMCE in Plone 5.2 is just a disgrace for content editors.

1 Like

Plone Foundation Code of Conduct