Switch visual editor (CKEditor to TinyMCE; reset personal preference)

I have a Plone site which traditionally uses CKEditor as the visual editor. Since I develop a new customization product now and need to create links to new content types (for embedding in the page text), I'd like to try TinyMCE because I'm not very happy with our CKEditor customization code (and I expect the TinyMCE integration to be better, with almost the whole community using it).

This is what I tried:

  • Changed the default_editor in the @@editing-controlpanel to TinyMCE
  • In the JavaScripts Registry, un-checked all CKEditor scripts, and checked both both members of the tinymce bundle:
    • jquery.tinymce.js
    • tiny_mce_gzip.js
  • activated Development mode
  • In the Bundles tab, replaced ckedit by tinymce for the Plone default theme;
  • In the Stylesheets registry, I checked the ++resource++tinymce.stylesheets/tinymce.css entry (Development mode is active)

... nothing helped. Either I got a CKEditor (if set to be the default), or I got nothing (i.e., upload only; not even a visible textarea).

Finally, I tried another user, and indeed I got the TinyMCE editor. It certainly looks like I have some personal choice stored somewhere; but I can't find a way to reset it.

  1. How would I reset my personal preferences to use the default visual editor?
  2. How would I do this for all users?

1). There is also /@@personal-preferences

if that does not work, it could be a javascript caching issue, try from another computer or another browser.

Yes, this is what I was looking for; thank you!

Plone Foundation Code of Conduct