Super simple Task management in Plone (5.1/5.2)

I am making a website for a school and different employees (teachers) are supposed to do different tasks. I am not talking about making the site, but about 'filling it with content'

Basically, teacher A should write document/page 'A', teacher 'B' should contact 'Person C' and do D (for example, take a picture).
And maybe ask 'Class F' to give feedback on something or make a video.

Currently, they use some googledocs, but it is a bit messy.
Is there anything simple I can use ( as teachers are not always too technical (?) I do not want them to install anything)

I think Products.Poi is perfect for such use cases.
I recently inherited a fairly old Plone site that had used Poi for a long time and I couldn't believe how useful it is to have it part of the site itself, and wonder why I hadn't come across it anywhere else (except for the old plone.org site).
Granted, you can't compare it to any modern issue trackers, but for simple task management it's perfect.

Thanks a lot.

I tried to locally install the 5.2 branch, but it looks like there is a lot of 'Archetype references', like

 File "/path/to/mysite/buildout-cache/eggs/plone.schemaeditor-2.1.0-py2.7.egg/plone/schemaeditor/configure.zcml", line 8.2-8.36
ImportError: No module named ATContentTypes.lib.imagetransform

Yeah, I have not yet used it on 5.2, so I can't say whether it will work or not.
But I do believe there is active work happening on a python 3 branch, which should have no archetypes references.

Product.Poi 4.0+ works on Plone 5.0 and 5.1 and only has dexterity. No Archetypes.
The various versions and how to upgrade are explained in the readme.

There is work for plone 5.2 going on in https://github.com/collective/Products.Poi/pull/51, muffled away under the title 'update tests'.

I used to be maintainer of Poi, but am not using it anymore, and not actively following development, but I occasionally review PRs.

The active branch for python3/plone 5.2 is "python3" (my pr was referencing to a wrong branch and i fixed it). Probably 52 branch is outdated btw.

We're testing it right now on a Plone 5.2 and it seems working.

Do you think there is a chance that it will Work on python 2.7 ?
(all addons I use on it are not updated, I think)

Plone Foundation Code of Conduct