[SOLVED] Unable to load extension: No module named 'local_extensions' when bootstrapping Plone 6 Project with Cookiecutter

I'm following the bootstrapping instructions over here

My intention was to recommend this approach for newbies, but... I've come across an issue:

After installing cookiecutter in a python 3.10 virtualenv, I ran the command below:

cookiecutter gh:collective/cookiecutter-plone-starter

Here's the output:

Unable to load extension: No module named 'local_extensions'

Solution: Simply launching a new terminal or running source ~/.zshrc was good enough in my case.

I somehow was using an older version of cookiecutter. I checked the version with this command:

cookiecutter -V

and it reported that I was calling cookiecutter version 1.73. Based on my reading, Local Extensions requires cookiecutter 2.1 or newer.

I think I have an unusual case. I'm on a Mac with conda installed. This was messing with my virtualenv. It seems that the path was not updated after running pip install cookiecutter and it was giving priority to an older installation of cookiecutter in my conda distribution. restarting the environment by launching a new terminal and reactivating my virtualenv cleared it up.


I was wondering why I got a notification to look at this post....

Sneaky edit :slight_smile:

Sorry about that @flipmcf ... I thought it was too much of a tangent. Hence the edit :slight_smile:

1 Like