[SOLVED] Jbot works on one Plone 5.2.1 site but not on another - looking for clues

I have two sites
Site A
Plone 5.2.1 using Python 3.6
standalone - based on unified installer

Site B
Plone 5.2.1 using Python 3.7
zeo - based on unified installer and uses plone_buildout user

On both of them I've added a product that relies on jbot to do overrides in a browser/overrides.
The overrides work on Site A but not on Site B.

Any clues why jbot would work in one context and then fail in another?

Specifically, I'm working on overriding album_view. Which means creating a file called plone.app.contenttypes.browser.templates.listing_album.pt in the overrides folder.
While both sites are using album_view for some reason Site B is reporting a different template.

Site A has template-album_view as one of the classes on the body tag.
Site B has template-plone-dexterity-interfaces-idexteritycontainer

That reads like the IIDNornalizer'ed version of a full Interface path. Very strange.

I tried to replicate the issue on the zope server running Site B by creating a new plone site (we'll call it Site C).
The new site (Site C) does NOT behave like Site B. Instead when I set album view on a folder I get:
template-album_view as one of the classes on the body tag, just like Site A :face_with_raised_eyebrow:

TTW view customizations?

… or another add-on that has registered another album view ?

Thanks @jaroel and @espenmn,
It was indeed a view overriding it and specifically through the web (TTW)
Witness the culprit:

I ended up deleting the customisation.

I wonder if jbot is capable of overriding that path? I have my doubts.

AFAIK view customization's are always prioritized.

1 Like

Plone Foundation Code of Conduct