[SOLVED] Failed to add a field to default dexterity content types

In a fresh installed plone 5.1.1, I tried to add a field to default dexterity content type File. But when I click "save default" , error output shows:

 Traceback (innermost last):
    •	Module ZPublisher.Publish, line 138, in publish
    •	Module ZPublisher.mapply, line 77, in mapply
    •	Module ZPublisher.Publish, line 48, in call_object
    •	Module plone.z3cform.layout, line 63, in __call__
    •	Module plone.z3cform.layout, line 47, in update
    •	Module plone.z3cform.fieldsets.extensible, line 65, in update
    •	Module plone.z3cform.patch, line 30, in GroupForm_update
    •	Module z3c.form.group, line 145, in update
    •	Module plone.app.z3cform.csrf, line 22, in execute
    •	Module z3c.form.action, line 98, in execute
    •	Module z3c.form.button, line 315, in __call__
    •	Module z3c.form.button, line 170, in __call__
    •	Module plone.schemaeditor.browser.schema.listing, line 118, in handleSaveDefaults
    •	Module zope.interface.interface, line 422, in getDescriptionFor
    KeyError: 'IRelatedItems.relatedItems'

Need your help. Thanks

Yes rings a bell, I think I created an issue on Github at some point.

1 Like