[SOLVED?] Archetype on Plone 5 - FSControllerPythonScript not running

I need a second eye on this, it's something I've done wrong somewhere.
I have a plone 5.1 build and trying to get an archetypes based product to work.

When I "save" this archetype, I get a text/plain page that says "<FSControllerPythonScript at content_edit>" and nothing else. The content_edit script isn't run. (it's in archetypes skins folder)

This breaks the add/edit workflow. It should go to the immediate view or just 'view' after save.


Source:


Disclamer: This was my first plone add-on I ever made, so it's full of hacks and mistakes. - it works in plone 4 and I'm trying to get a plone 5 version

It's archetypes based. Not going to make a dexterity product yet because of some field storage tricks I'm using.

Kaltura is a cloud-based video DAM, and this add-on syncs videos uploaded into Plone to the DAM, so it feels like you're managing the video on Plone. Once the plone5 basic work is done, I'll probably do a real release to pypi

Since AT will not be supported under Python 3, you are doomed. Controller scripts are a culprit of the last decade. Totally dead and outdated by all means.

Unhelpful.

This is why I specifically mention I'm running plone 5.1 (python 2.7.latest) and that's my release goal.

I'm upgrading from 4.2 to 5.1 and this is the ONLY archetypes product I'm trying to keep. I can't succeed without this kaltura support, and I am trying to avoid the dexterity rewrite.

I'm doomed when it comes to 5.2, yes - and I'm kicking that can down the road.

There must be something not turned on to actually 'run' controller scripts on plone 5.1.
I'm willing to turn it on and hack it for this product - until I can get it migrated to a dexterity type

Unhelpful but reality

Migrate your cruft before the cruft survives you

I am getting this same behavior but in a different context : PloneFormGen. Was working fine but suddenly, today, find I cannot create PFG forms without getting this message. The white page never dies, but the new PFG form items are there when you go to the folder-contents view. Plone version 5.1.5. Will post this case elsewhere.

1 Like

@wm_fennie where else did you post this? Any followups yet?

I have a solution, but I'm not sure of the side effects.

Visit the ZMI, go to 'portal_form_controller' click the 'actions' tab and remove the 'validate_integrity' transition line. (the last one on this screenshot)


I have a very shallow understanding of what I'm doing when I remove this line - I'm killing versioning on ALL actions through form controllers.

I'm not sure why this is causing a problem, but I do know:

  1. 'update_version_on_edit' was a .cpy in the CMFEditions skins at version 2.1.3 and now it's a browser view for 3.2.2.

2) CMF Editions 3.2.2 seems to add these actions during install.

don't have any actions define in the ZMI for my plone 4 build with CMFEditions 2.1.3. I am NOT sure if the lack of actions on my plone4 install is by design or by default install.

1 Like

Seems that dev's are providing the same workaround as what I came up with. This is the right track:

PING @MrTango any thoughts here?

Thanks for this. I will try it on my own case and report back. I haven't posted this as a PFG issue yet, and perhaps there is no need.

This solved my problem in Plone 5.1.5. I will follow up with the fixes mentioned in this thread relating to re-running an update step. I, too, am in the dark about unintended consequences of this TTW edit.

1 Like

Re-running the GS Profile for CMFEditions (ZMI->Portal Setup -> Import -> Select 'CMFEditions') "Import All Steps" Will remove all the transitions, fixing the problem.

There may be unintended consequences with versioning of AT Types. However, Plone 4.1 Didn't have this behavior AFAIK

Thank you CMFEditions for supporting us Archetypes people.

Plone Foundation Code of Conduct