Setting up plone

Setting up plone on macos, I am running this command
sudo pipx run cookiecutter gh:collective/cookiecutter-plone-starter

but getting this error:

Could be related to this: Plone 6 Volto generate app - Cannot find module 'is-ci'?

If you are executing the comand with root user try to execute with your user instead as yo (Yeoman) fails when executed as root

when I am not using root user ( executing without sudo ), I get permission denied error

Either assign permissions to .cookiecutters folder or delete it and start over

I deleted .cookiecutters and .cookiecutter_replay

and I ran without root permission

pipx run cookiecutter gh:collective/cookiecutter-plone-starter

deleted folders again and ran with root permission

sudo pipx run cookiecutter gh:collective/cookiecutter-plone-starter

Following this documentation: Create a project – Install — Plone Documentation v6.0 its working fine for me on Ubuntu 22.

What documentation are you following? Did you install nvm, node and yo with your current user? If not you could try to delete the .nvm and .npm folder and retry

Delete aswell the project folder if already created

I am using mac and I have installed all the dependencies

versions, I am using:
yarn - 3.8.0
node - 20.11.1
nvm - 0.39.7
yo - 5.0.0

I am following the same documentation, also I deleted all the dependencies and tried again, I just keep getting this same error, is there any other way I could install this project?

Hi @vishwajeet26 please share your error logs as text. For two reasons:

  1. easier for those helping you to read and copy/paste
  2. the output gets indexed by Google and helps others who have the same issue in the future.

If you quote them with triple backticks "```" at the beginning and end then this:

ends up displaying like this:

my error log
with my errors