Schema with plone.app.vocabularies.UserFriendlyTypes not saving

I have a setting in a theme fragment that is not saving (I think since self.data['kontent_type'] returns '' no matter what I choose. All the other fields save OK and I see no errors.

  <field name="kontent_type" type="zope.schema.List">
    <title>typer</title>
    <value_type type="zope.schema.Choice">
      <vocabulary>plone.app.vocabularies.UserFriendlyTypes</vocabulary>
    </value_type>
  </field>

PS: If I use schema.Choise it works:

   <field name="kontent_type" type="zope.schema.Choice">
    <vocabulary>plone.app.vocabularies.UserFriendlyTypes</vocabulary>
  </field>

Any suggestions?

Have you tried with "default" and "missing_value" properties?
Which Versions are in use? Because on plone5.2.2 your example is working for me.

After basically giving up last night, I found some old code in another fragment and tested that.
It worked.
After duplicating that fragment, the duplicated fragments did not work, and I discovered that it was because of the name

Turned out that if a fragments has a name with '-' in it, it will not save this field correctly. All other fields saved OK.

So, simply changing my fragment from

news-copy.xml (.pt / .py) to news_copy.xml it works

( I had used duplicated working templates, and the OS gave them a name with '-'

Plone Foundation Code of Conduct