Running a Page Template in ZMI of Plone 5 fails - a bypass

I tried to run this Page Template created at the root of my Plone website and got an error.
Note that the CSRF feature is switched off in buildout.cfg
environment-vars =

The page template contained this:
<title tal:content="template/title">The title</title>
<meta http-equiv="content-type" content="text/html;charset=utf-8">
<h1 title="${template/title}">

I am working in the ZMI.
When I run test Plone responses with "The page does not seems to exist" and URL becomes: http://localhost:8080/Plone/ZScriptHTML_tryForm

After each save of the page template code I first visit the root of the website /Plone and then go back to reopen the page template file and run test again. Then it works until you change and save the code. Repeat the step above and test works again. Funny... and akward.

What is happening here? CSRF is switched off ...

CSRF shouldn't matter at all for page templates.

Seems rather like there is a bug in the page template edit page urls. After you save, all the urls become wrong. If you click on the breadcrumb of the template you created/edited/etc, the urls in the tab for "test" and other things are correct again.

Or you can just manually open up the template directly in another tab and test that way instead of having to click the "Test" button.