Problem with buildout Plone 5.08


I'm using Ubuntu 12.02, Python 2.7.3

Working on
Theme Package I: Preparations

After a lot of research for installing nodejs (6) and npm
I ended at
(buildoutvenv):blush: buildout bootstrap

Problems came up with running buildout:

(buildoutvenv)root@www:/opt/plone5/ploneconf.theme# ./bin/buildout
Loading extensions.
Getting distribution for 'mr.developer==1.35'.

An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 1995, in main
getattr(buildout, command)(args)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 507, in install
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 1032, in _load_extensions
newest=self.newest, allow_hosts=self._allow_hosts)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 859, in install
return installer.install(specs, working_set)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 643, in install
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 488, in _get_dist
dist, avail = self._satisfied(requirement)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 253, in _satisfied
return None, self._obtain(req, source)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 431, in _obtain
if _final_version(dist.parsed_version)
File "/opt/plone5/buildoutvenv/local/lib/python2.7/site-packages/zc/buildout/", line 1476, in _final_version
return not parsed_version.is_prerelease
AttributeError: 'tuple' object has no attribute 'is_prerelease'

Any hints ?

Regards, FL

I first tried what is proposed in answer 10 of Help trying to install Plone without Vagrant on Ubuntu 16.04
Used instead of develop.cfg the buildout.cfg

I had to do some more manual "pip install ..." taking into account, that we need the SSL index option: --index:

After that, it worked.

Other proposal: Start the whole training manual again. In between there seemed to be something wrong during installation and purge processes for nodejs and npm.

Hope it is helpful for anyone working with Ubuntu 12.02

Regards, FL

Sorry, it even now does not work.

See: TypeError: 'Version' object has no attribute '__getitem__'

I tried the tutorial on a fresh Ubuntu 16.04 LTS VM it worked with the following quirks

sudo apt-get python python-dev
sudo apt-get install nodejs-legacy
sudo apt-get install zlib1g-dev libjpeg-dev libxml2-dev libxslt1-dev
edit buildout.cfg to replace http by https in extends and add an index stanza
index =

I have no idea why you should get a too recent setuptools with this procedure.
You can check the version by launching the virt env

source buildoutvenv/bin/activate
>>> import setuptools
>>> setuptools.__version__

if you get that your should not get this message when running bin/buildout in the virtual env as said in the doc

Maybe you could try again with a less outdated OS version as Ubuntu 12 is long out of support.

Off the top of my head...does it help to

bin/pip install setuptools==38.7.0