Problem while installing plone.restapi

Hello everyone. I'm Victor and I'm new to Plone. I have been learning python and JavaScript for the last 8 months. I decided to contribute to plone.restapi.

I ran into an issue while installing plone.restapi.

  • I ran the make command
  • added eggs = plone.restapi to buildout.
  • On running bin/buildout I'm getting the error
    Error: The requirement ('importlib-metadata<4.3,>=1.1.0') is not allowed by your [versions] constraint (0.23)
    I tried removing importlib form versions.cfg and run it , but it did not work .

Can anyone please provide some solutions to the issue.

Which plone.restapi are you trying to install under which Plone version?

This is the one. I guess the Plone version is 6.
I am new here so I don't know a lot of things.
In order to install it , I just made a fork of plone/plone.restapi(GitHub - plone/plone.restapi: RESTful API for Plone.)
then cloned it to my local system. I tried to follow the instructions in readme.
Is this the right way or Am I mistaken.

I suggest you to open an issue to the plone.restapi repo.

I skimmed the files there and noticed that running make tries to install Plone 5.2.
For that version there are some additional pins:

They are effective if you use Python 3.6 or Python 3.7.

They should be actually used for every Python version.
Try to remove this line plone.restapi/plone-5.2.x.cfg at 2dc837302472d68e61e958e617c4085b3fcb432c · plone/plone.restapi · GitHub
and rerun make to see what happens.
You might be very close in creating your first PR for that repo.

Note that the supported Python version for Plone 5.2 are Python2.7, Python3.6, Python3.7, Python3.8.

So take care of which Python version you are using.

If you want to try Plone 6 try:

make build-plone-6.0

your experience should be smoother.

But as mentioned it is better if you open an issue on the repo and it would be great if you could provide a PR with a fix.

Ok @alert , Thank you. I'll raise the issue and try to fix it.

In order to understand the project. I'm learning Rest api's and zope currently. Is there anything else I should learn in order to understand the project better.

Is this description all right for raising the issue.

a typical bug report should contain:


Read first!

Please use the labels at Github, at least one of the types: bug, regression, question, enhancement.

Please include tracebacks, screenshots, code of debugging sessions or code that reproduces the issue if possible.
The best reproductions are in plain Plone installations without addons or at least with minimal needed addons installed.

What I did:

What I expect to happen:

What actually happened:

What version of Plone/ Addons I am using:

Ok , thank you.

@alert I ran make build-plone-6.0 using python 3.10. Even this one gives the same error as before.
I tried removing removing plone.restapi/plone-5.2.x.cfg at 2dc837302472d68e61e958e617c4085b3fcb432c · plone/plone.restapi · GitHub
I am getting a value error:

I'll look into it and try to fix this issue and make my first pr.