Problem migrating from 4.3.20 to 5.1 or 5.2

Hello

I have two plone sites , one is an oldy site upgraded from plone2.1x to 4.3.18 ; the other one is say 8 years old, runing 4.3.18

I'd love to migrate both site to ... well i'd like it to be python3 ; but 'ill stick to py2 for now

My first task would be to upgrade the smallest easiest site to 5.2.

buildout just states

eggs =
    Plone
    Pillow
    plone.app.ldap

I added plone.app.contenttypes in 4.3
@atct_migrator went fine on plone 4.3 ;

but when i try performing the upgrade ( to 5.1 or 5.2 ) , i have a
AttributeError: type object 'IFieldValueSetter' has no attribute '__iro__'

I tried removing the ldap plugin but the same thing occured

I am a bit worried to have these problems in the small-easy .. and i fear what will happen with the bigger one

Thanks for your help / hints

Fred

perhaps: Cleaning up a wicked mess - #7 by Esoth

thank you, but adding unwicked as an egg gave the following error :

[...]
File "/opt/Plone-4.3.18/zinstance/src/unwicked/unwicked/init.py", line 1, in
from plone.app.upgrade.utils import alias_module
zope.configuration.xmlconfig.ZopeXMLConfigurationError: File "/opt/Plone-4.3.18/zinstance/parts/instance/etc/site.zcml", line 12.2-12.39
ZopeXMLConfigurationError: File "/opt/Plone-4.3.18/buildout-cache/eggs/Products.CMFPlone-4.3.20-py2.7.egg/Products/CMFPlone/meta.zcml", line 42.4-46.10
ImportError: No module named app.upgrade.utils

Why did you add plone.app.contenttypes to your Plone 4.3 site?

You don't need that:You can create a new Plone 5.2 instance with the last/latest python 2, put a copy of your Plone 4.3 content db in/under that install, run the upgrade steps and then run the atct_migrator

It is also in the Plone 5.2 install where you would add the unwicked add'on .

I tried the 'normal' migration path, but i never succeeded

I tried to cleanup the wicked mess ... but this addon does not work when i add it to a fresh instance 5.1

Plone Foundation Code of Conduct