Problem in plone 6 installation

I tried everything but on
pipx run cookiecutter gh:collective/cookiecutter-plone-starter

I got this error
Error while running ['make', 'format']:

  • which python3
  • python3 -c 'import sys; print((int(sys.version_info[0]), int(sys.version_info[1])) >= tuple(map(int, '''3.8'''.split('''.'''))))'
  • dirname /home/anshul/my_project/project-title/backend/Makefile
    ++ tput setaf 2
    ++ tput sgr0
  • echo '==> Format codebase'
    +++ whoami
    ++ id -u anshul
  • docker run --rm --user=1000 -e LOG_LEVEL=INFO -v /home/anshul/my_project/project-title/backend:/github/workspace plone/code-quality:2.1 format
    docker: permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/create": dial unix /var/run/docker.sock: connect: permission denied.
    See 'docker run --help'.
    make: *** [Makefile:118: format] Error 126

ERROR: Stopping generation because post_gen_project hook script didn't exit successfully

Welcome to Plone Community!

This error seems to be a user permission related issue. Probably your unprivileged user does not belong to the docker group.

You can check it was successful by doing grep docker /etc/group and see something like this in one of the lines:


If not, you can do:

sudo usermod -a -G docker $USER

Then change your users group ID to docker (to avoid having to log out and log in again):

newgrp docker

And try again.


1 Like

Ok, I'll try doing it.

Hello Rafel, first of all thank you for your response. But I tried doing that and it is showing docker:x:998:[myName], but the problem remains same.

Can I ask you something like what is format? There was the error of that, do we need to manually install it?

That's correct.

Try checking the permissions of the Docker daemon socket by running:

ls -l /var/run/docker.sock

The output should show that the socket is owned by the "docker" group and has read and write permissions for the group.
If the permissions are incorrect, you can adjust them with the following command:

sudo chmod 666 /var/run/docker.sock