Post_gen_project hook script didn't exit successfully Installing plone

I installed plone before after a lot of issues. This time I tried again to reinstall the plone using packages and again I am not able to install it.

post_gen_project hook script didn't exit successfully

Running sanity checks
  - Python: ✓
  - Node: ✓
  - yo: ✓
  - Docker: ✓
  - git: ✓

  - Plone version: 6.0.3
  - Volto version: 16.18.0
  - Volto Generator version: 6.3.0
  - Output folder: /Users/flekenstine/Desktop/work/plone/plone/project-title

Frontend codebase:
 - Installing @plone/generator-volto@6.3.0
 - Generate frontend application with @plone/volto 16.18.0
There was an error, see /Users/flekenstine/Desktop/work/plone/plone/plone_starter_error.log for details
ERROR: Stopping generation because post_gen_project hook script didn't exit successfully
Hook script failed (exit status: 1)

Anyone who can guide me ?

Which node JS version is it?

node 16.13.0

Is it winodws? Try checking the file /Users/flekenstine/Desktop/work/plone/plone/plone_starter_error.log of your system. You might find some useful info there. And moreover I think this is an error in a library that volto uses. Tho I am no expert in this, so I can be wrong too. This is all I could help.

Try installing not in /Users/flekenstine/Desktop because that is a protected directory by macOS. Instead try /Users/flekenstine/projects/my-awesome-project-name-with-hot-sauce.

1 Like

Are you trying to execute frontend or backend code on your local. Or are you installing plone as an application?

What do you mean by an application? I am using the package method to install it. I suppose we have two methods one is docker containers and the other is the package method.

Let me know if we have any other.

Concluding: I am still not able to install with
cookiecutter gh:collective/cookiecutter-plone-starter

the error that is in the log file is

Error: EACCES: permission denied, open '/Users/flekenstine/projects/bookus/frontend/package.json'
    at Object.openSync (node:fs:585:3)
    at Object.writeFileSync (node:fs:2153:35)
    at write (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/mem-fs-editor/lib/actions/commit.js:15:6)
    at DestroyableTransform._transform (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/mem-fs-editor/lib/actions/commit.js:49:7)
    at DestroyableTransform.Transform._read (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_transform.js:166:10)
    at DestroyableTransform.Transform._write (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_transform.js:155:83)
    at doWrite (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_writable.js:390:139)
    at writeOrBuffer (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_writable.js:381:5)
    at DestroyableTransform.Writable.write (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_writable.js:302:11)
    at DestroyableTransform.ondata (/Users/flekenstine/.nvm/versions/node/v16.13.0/lib/node_modules/@plone/generator-volto/node_modules/readable-stream/lib/_stream_readable.js:629:20) {
  errno: -13,
  syscall: 'open',
  code: 'EACCES',

It can be a problem with my cookiecutter maybe it does not have permission to get the code from any URL.

Last month I did was cloned the cookiecutter existing repo in my local pc and then used the command cookiecutter . this worked same and I was able to install.

What I messed up this time?
My docker was not running and when I once again tried cookiecutter . the local method it showed me an error and, unfortunately, I did not check the error log @rahilhastu thanks for pointing this out.
now I went and checked the error

docker: Cannot connect to the Docker daemon at unix:///Users/flekenstine/.docker/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.
make: *** [format] Error 125

Started the docker and used the same local method cookiecutter . and things went smoothly like last time.