Plone Upgrade 5 Failing - ComponentLookupError: (<InterfaceClass plone.registry.interfaces.IRegistry>, '') after upgrading from Plone 4 to Plone 5

Hi Team,

We are in process of Upgrading our Plone 4 to Plone 5. We are done with all the code modifications and successfully ran the build out. We initially got the message 'Info: Zope Ready to handle request'.
After that when we hit the URL in browser we are getting 'ComponentLookupError: (, '')'. Kindkly refer to the attached logs:

Also when we try to hit the ZMI, we are getting Attribute Error(Portal registry) :

AttributeError('portal_registry',) (Also, the following error occurred while attempting to render the standard error message, please see the event log for full details: (, ''))

Please let us know if we can provide you more information.

Thanks &


are you using portal_skins > custom

if you have a custom main_template there it may be related to that

Plone 4 does not includes by default; you should probably have to upgrade to an intermediate version of Plone, install it and then upgrade to Plone 5.

Hi This is Farha,

Now, we are trying to upgrade Plone 4.3.9, from Plone 3.3.5 and i am again stuck at same place.

@rnunez no we are not using custom main_template.

@hvelarde I tried installing both Plone registry and, but nothing worked i am still stuck at same error

probably you need to stop on version 4.0 and install before upgrading to a newer version.

you will have to use the following pinning:

if that does not works, I would suggest you to use another strategy to upgrade; Transmogrifier is your friend: