Plone sandbox deloyment to Heroku failed

Hey guys, the issue for this package is described here. I think pinning the versions of the packages that generate version conflicts while running the buildout can solve this problem. I did this in this pull request and the problem was fixed when I pushed to Heroku again.
Can you guys let me know if this is okay?

Thank you.

Setuptools strikes again! Looks fairly sane to me.
It bit me during training last week, didn't stop to check at the time.

Yeah I tried to pinned those packages version and it worked again (based on the traceback). Do you think it is a good idea? It is in my pull request.

I don't know if it matters for the training-sandbox but, have you signed the contributor's agreement? Given that you're contributing via pull request it is most likely needed.

I think it's a good idea, but I'd want a second opinion. I've been bitten enough by setuptools to lean towards pinning it at this point.

Yeah I signed the Contributor's Agreement and I am in the Plone repositories.
I think fixing this is still necessary since the link to Deploying Plone on Heroku will be affected. I tried to run that buildpack on Heroku and that same problem occurred. Most importantly, that is the link on the official Plone download page. So giving a temporary fix might be a choice at this time before we can move on with other problems.

@tkimnguyen the heroku button will need to be updated to Plone 5.0.7 on the website. I tested it against the heroku-buildpack 5.0.7 branch and it works as expected.

I took a quick look a few days ago and it didn't seem to be as simple as I always hope things are :confused:

A few days ago we had the setuptools issue, maybe that could have explained the weirdness you experienced.