Plone.restapi>=8.13.0 is not allowed by your [versions] constraint

Looks like the constraints needs to be updated or overridden to allow plone.volto installation with python 3.9

$ mkdir Plone-5 

$ python -m venv .

$ source bin/activate

$ echo '[buildout]
parts = instance
extends =
    https://dist.plone.org/release/5.2-latest/versions.cfg

#versions = versions

[instance]
recipe = plone.recipe.zope2instance
eggs =
    Plone
    plone.volto
' > buildout.cfg

$ ./bin/pip install -r https://dist.plone.org/release/5.2-latest/requirements.txt

Running './bin/buildout -vvv' resulting in following constraint error:

We have the distribution that satisfies 'Zope==4.6.3'.
Getting required 'ZODB==5.6.0'
We have the distribution that satisfies 'ZODB==5.6.0'.
Getting required 'ZEO==5.2.2'
We have the distribution that satisfies 'ZEO==5.2.2'.
Getting required 'Paste==3.5.0'
We have the distribution that satisfies 'Paste==3.5.0'.
Version and requirements information containing plone.restapi:
  [versions] constraint on plone.restapi: 7.5.0
  Requirement of plone.volto: plone.restapi>=8.13.0
  Requirement of Plone==5.2.6: plone.restapi
While:
  Installing instance.
Error: The requirement ('plone.restapi>=8.13.0') is not allowed by your [versions] constraint (7.5.0)

plone.volto 3.1.0a5 requires at least plone.restapi 8.13.0:

Just pin this version in your buildout.cfg:

plone.restapi = 8.13.0
1 Like

Plone Foundation Code of Conduct