Plone installation - beginner

Hello everybody!
I'm Antoine, a new Plone's user working on Windows 10. I'm completely beginner in Plone so don't judge me...:joy:
I have installed Plone following this tutorial: .
It worked perfectly and I was on Plone for a few minutes. But then I turned off my computer and it's impossible to go back to the Plone interface... I tried to run Wamp but I didn't do that the first time so I'm completely lost...
Anybody could help me?
Thanks !

You need run Plone using bin/instance fg after a reboot or install Plone as a Windows service.


Hi AJ!
Thanks for your answer!
could you tell me how to install Plone as a Windows service?

No idea. Apart from foreground mode you can also start Plone in background using bin/instance start.


I tried the 2 methods and nothing works...

a guess: first 'instance start' launched a Plone in background, then the second one blocks on the first. Try to use the task manager to kill the hidden Plone or restart the computer

IIRC there is a Windows installer on the site, how about just using it ?
installing a python script to a Windows service can be a bitstrong text involved I'm afraid.

I tried this method ( ) but the 5th step don't work... Here is the error:

Plone's installation on Windows isn't really intuitive...
Anybody could help me? :grin:

you seem cursed :slight_smile:
Actually I was thinking from some posts on this forum that Plone had got (again) a full Windows installer and it seems not, it's still at the beta stage. So it is this vagrant kit. Mind you the beta windows installer seems to use the same trick but more wrapped.

Anyway, with your first method, I still think that Plone was started the first time and the Zope message was just a spurious error message, and it was for this reason that you could not start it with the 'fg' parameter.

About your other try with the Vagrant kit, it seems that the directory already exists. Duckduckgo says that it is the result of a previous failed installation, and that the fix is to use the Oracle manager to delete any existing VM, then deleting the problematic directory (that would be c:\users\antoi\virtualbox vms\plonedev in your case), then try again. If it fails again after having purged everything, you should file an issue at github for this project.

Mind you, there can only be one Plone started with default config .
If the first Plone is still running (check with the task manager I said) the Vagrant kit will have trouble taking over the 8080 port. So use one method or another, but not both at the same time.

1 Like

I'm cursed! Thank you, I'll try again clearly with the Vagrant kit... :relaxed:

Hi everybody ! I'm a bit annoyed by the situation... I tried to delete all the files, desinstall everything and reinstall Plone with the first method.. It worked again but after rebooting my computer, same problem...
"The program seems already to be running. If you believe not, check for dangling .pid and .lock files in var/."
and I only lauched instance fg....
Any ideas?

I found the solution!
Here is she:
" You can try the following steps:

-Find the running process id by opening the .pid file within your instance's var/ directory.
-Open the Windows Task Manager and stop the running process with the above identifier.
-Delete all .pid and .lock files in your instance's var/ directory.
-Start your instance.


-Run services.msc
-Search for Plone 4.3
-Try Starting or Stopping it along with your instance"

From what you say, it seems that starting Plone with instance fg does not clear the lock and instance file when you stop Windows without hitting Ctrl C to stop Plone. If you can confirm that then it's a bug and you could file an issue.
The info about service is outdated Windows has changed but this part of Plone has not followed the evolution, don't try to use services.msc.

Yep that's right, I need to do it manually... I confirm.

This sounds like a potential ZServer bug (as in it'd not be listening to the signals appropriately at Windows shutdown time correctly to initiate a graceful shutdown).

Can you fish the exact ZServer version out of your version pinnings?

I will translate from Plonish to english: the Zserver version can be found under a directory called 'buildout-cache\eggs', with name starting by 'Zope2'. I'd expect it should be something like Zope2-2.13.26 if I am following correctly the install process of simple-buildout.

Now as the code responsible for this (Signals/ has not changed since at least 10 years and Windows 10 started to ship in 2015, and that the code states at the beginning that

'The signal can be set by any user with the correct permission'

I'd prepared to think that Plone (actually Zope) code was written in happier days where everyone had admin rights on the computer while now it's more usual to have users with limited rights by default. Maybe you could try to launch Plone from a console started with elevated rights to see if it changes anything when your stop your computer without having stopped Plone first.
Or,well, punt out and just add a small script to delete the lock and instance files at boot time.

Exactly !

and ? did you try the elevated console trick ?