Plone 6 Python Version Support?

Which Python version do you need upcoming Plone 6 to work with?
Please check only values you really need!

Please comment if you need 3.6 or 3.7 and explain why.
Mind that Python 3.6 is end of life 12/21.

Plone 6 expected Python support
  • Python 3.9
  • Python 3.8
  • Python 3.7
  • Python 3.6

0 voters

We are currently mainly using Python 3.7. We still have lots of servers that use 3.7 as system Python. Our devs also run into lots of issues with Python 3.8 and 3.9 on OS X lately. I couldn't set up 3.8/3.9 on my new M1 MB pro the other week (did not try very hard though tbh).

my 2c: 3.6 for Plone 6 does not make any sense. I would like to keep 3.7 for a while though if that's possible without too much hassle.

Thanks for looking into this and bringing this up Jens!

1 Like

Plone Foundation Code of Conduct