Plone 6 beta 1 released

Good news: the first beta release of Plone 6 has arrived!

For technical wizards who want to jump straight in, here are two important links:

See the release page on plone.org for more info.

Highlights

Major changes since 6.0.0a6:

  • Products.CMFPlone:
    • Removed our expressions patch. This was a patch to avoid some too strict checks by Zope / Products.PageTemplates. But in Plone 6 it should be fine to be stricter. The STRICT_TRAVERSE_CHECK environment variable is no longer read.
    • Initially open accordions in resource registry. Hide via JS when no errors occur. This makes it possible to fix a breaking error.
    • Resource bundle dependency on multiple comma separated names.
  • plone.staticresources:
    • Register jquery and bootstrap globally. This helps a lot for add-ons.
    • Fix tinymce link/image modals.
  • plone.dexterity: Remove long deprecated imports and fallbacks.
  • plonetheme.barceloneta: Update to Bootstrap 5.2.0 (released this week).
  • plone.scale: Fix to ensure that when a scale that was registered using pre_scale is later actually generated by get_or_generate, it is stored with the same uid as the placeholder info that was stored by pre_scale. This avoids an issue where the same scale was generated repeatedly.

Volto frontend

The default frontend for Plone 6 is Volto. Latest release is 16.0.0-alpha.15.
This contains the much anticipated integration of the volto-state editor. See the changelog.

Python compatibility

This release supports Python 3.7, 3.8, 3.9, and 3.10.
Support for Python 3.10 is still a bit provisional, as our testing infrastructure needs some updates before we can fully test this.
But your friendly Plone Release Manager is using Python 3.10 for local development, so it should be okay.

Installation

For installation instructions, see the documentation.
This documentation is under development, but this should get you up and running. No worries.

13 Likes

I checked out buildout.coredev branch 6.0 from Github [Plone 6.0.0b1 (6006)] and created a new site inside my current database. I had a former Plone site inside it. I named the new site Plone2. I created some content with a Plone add-on (collective.templates) inside this new Plone site. Then I deleted the first site (Plone) and renamed the second one from Plone2 to Plone. The configuration (in this case the mail setting and the installed add-ons) remained in the renamed site, but the content wasn't available/visible anymore. It was not shown in the view and also not in the content listing. But I got an error message, once I tried to create a new content object with the same name inside the new site. It seemed the data of the former content object were still present in the database.

@andreasma From what I recall, renaming a Plone site has always had some issues and is not really supported. Maybe you just need to rebuild the catalog?

Is it a a Volto-based or classic site?

@davisagli it was currently a Plone classic ui site.

Removing earlypatches/expressions.py in Removed earlypatches/expressions.py. ยท plone/Products.CMFPlone@0de3c3c ยท GitHub breaks sites with old skin-based templates.
I have a old site that uses skin templates that call context/main_template/macros/master and in 6.0.0b1 all of these are broken with zExceptions.NotFound: zExceptions.NotFound: macros.

I'm not sure if we should force everyone to stop using addons that use such a pattern (or update them). Is there another way to fix these than to rewrite all skin templates to BrowserViews?

I created a ticket for that: Removing expressions-patch breaks sites with skin templates in 6.0.0b1 ยท Issue #3581 ยท plone/Products.CMFPlone ยท GitHub

1 Like

I was going to play with the docker images created by @ericof, is there a plan to release an official ZEO container for the 6.0 final version?

1 Like

Maybe bump the requests version? On debian bullseye, I got this on startup:

(venv) root@plone6:/usr/local/Plone# runwsgi ./instance/etc/zope.ini
2022-07-29 21:13:04,579 INFO    [chameleon.config:38][MainThread] directory cache: /usr/local/Plone/instance/var/cache.
/usr/local/Plone/venv/lib/python3.9/site-packages/requests/__init__.py:102: RequestsDependencyWarning: urllib3 (1.26.9) or chardet (5.0.0)/charset_normalizer (2.0.12) doesn't match a supported version!
  warnings.warn("urllib3 ({}) or chardet ({})/charset_normalizer ({}) doesn't match a supported "

Updating requests to 2.28.1 fixed it for me:

(venv) root@plone6:/usr/local/Plone# pip install requests==2.28.1
Collecting requests==2.28.1
  Downloading requests-2.28.1-py3-none-any.whl (62 kB)
     โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ”โ” 62.8/62.8 kB 2.0 MB/s eta 0:00:00
Requirement already satisfied: idna<4,>=2.5 in ./venv/lib/python3.9/site-packages (from requests==2.28.1) (3.3)
Requirement already satisfied: certifi>=2017.4.17 in ./venv/lib/python3.9/site-packages (from requests==2.28.1) (2021.10.8)
Requirement already satisfied: charset-normalizer<3,>=2 in ./venv/lib/python3.9/site-packages (from requests==2.28.1) (2.0.12)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in ./venv/lib/python3.9/site-packages (from requests==2.28.1) (1.26.9)
Installing collected packages: requests
  Attempting uninstall: requests
    Found existing installation: requests 2.27.1
    Uninstalling requests-2.27.1:
      Successfully uninstalled requests-2.27.1
Successfully installed requests-2.28.1

We get the requests pin from Zope. The next Zope version will contain version 2.28.1.

After updating Plone Classic UI from a4 to b1 I got Javascript errors, like Jquery was not found in plone.session. After I restarted the whole cluster all problems are gone. Are there some caches left after upgrade?

We already have one: plone/plone-zeo โ€“ Install โ€“ Containers โ€“ Official Images โ€” Plone Documentation v6.0-dev

1 Like

I'm running the new 6 beta 1. Easy install, guys. Kuddos!

One odd thing that I noticed about this release and some of the Alphas, namely: at the home page, you can add an Event, File, Image, Link, News Item, and Page. However, you cannot add a Folder. Am I missing something? Adding folders at the root level is de rigueur. Indeed, that's the very thing that the site developers add first. Surely this was an oversight. Surely.

One other quirk. I had created a Page object titled "Test". Then I deleted the page (hence the Contents view showed only three items). You can see the informational "Successfully delete items". However, if you look at the screenshot (above) you'll see that the "Test" link is still visible on the main line after "Users". Of course, if you click on the link you'll get a 404. Should that line be updated after a delete, perhaps?

By the way, that informational message should have read "Successfully deleted item(s)." Past tense.

seems a caching problem of the navigation toolbar

I think this is because Volto has Page, Event and News Item as folderish types and can contain items inside. If you want the classic behavior, you can create a Plone site with the new Button Create Classic Plone site. There the Folder is still alive.

Peter: What I was seeing is that the selection for the Folder object (in general) was missing from the selection list. If you look at the allowed content types for the Page object (see image below) you'll see an entry for "Folder" but that particular allowed type is not showing up as one of the selections available for "Add new..." under Page objects. For some reason, the Page object can (with its Folderish property) can "Add new..." everything except a Folder object.

HOWEVER! If you go and edit the content type for the Page object, select "Some content types:" and just select all of them (including Folder), only then are you able to add a Folder object to the Page via "Add new...". For some reason, the selection for "All content types" isn't including the Folder object.


My guess is that problem also affects the root folder as well. Hence, the inability to add Folder objects at the site root.

As @petschki said: you should create a plone classic site, then the option to add folders will appear

@ronc That is what Peter meant. In Volto there is no need to add a Folder on any level. You just add a Page, which is basically a Folder plus rich text. Among other reasons, this avoids the need to create a Folder and a default page, which was unintuitive for some people.

Also, I don't think you are supposed to use this classic Plone interface, but use the new Volto user interface. See for example https://6.demo.plone.org. The classic interface should still work in combination with Volto, but there might be some quirks.

@mauritsvanrees Thanks for the explanation. Incidentally, I didn't ask for the old interface. It just came with the installation. I was expecting the newer Volto interface, and was surprised that the Volto interface looked so much like the classic one. Is there a way to switch?

You probably haven't installed the frontend yet: Install Plone from its Packages โ€“ Install โ€” Plone Documentation v6.0-dev