Plone 6.0.5 Classic, problem installing 'Cheetah'

On ubuntu ( 20.04.5 / python3.9 ), I tried to install latest Plone (6.0.5)
Everything seems to install as it should, until I get to 'Cheetah'
I tried with different versions of pip/setuptools.
Any suggestions?

 Gettingting distribution for 'Cheetah<=2.2.1,>1.0'.
  error: subprocess-exited-with-error
  × python egg_info did not run successfully.
  │ exit code: 1
  ╰─> [9 lines of output]
      Traceback (most recent call last):
        File "<string>", line 2, in <module>
        File "<pip-setuptools-caller>", line 34, in <module>
        File "/tmp/pip-req-build-plpnsa3u/", line 10, in <module>
          import SetupTools
        File "/tmp/pip-req-build-plpnsa3u/", line 64
          raise ValueError, 'The entries in "data_files" must be strings'
      SyntaxError: invalid syntax
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

Cheetah is not a dependency of Plone, so you need to figure out what else is causing it to get installed (maybe an addon?). It looks like the specified range of versions for cheetah is quite old and does not support Python 3.

Thanks, it looks like it was one 'parts=' in the buildout.
(I have a site with 'minimal plone buildout that I 'updated')