Plone 5.2 r3 installation failed with socket.timeout: timed out in traceback

I tried to install Plone in debian buster using vmware workstation and never worked in the past two month.
"socket.timeout: timed out" is the end of install.log.
This is one of my install.log: https://pastebin.com/KR2V9KsP
I think it is the problem of so-called great fire wall in mainland of china, but my vpn service does not work for this.

Need your help.
Hugo

After installed some libs using "sudo apt-get install python3.7-dev python3.7-tk python3.7-venv build-essential libssl-dev libxml2-dev libxslt1-dev libbz2-dev libjpeg62-dev", I got a small step forward.
Now the install.log shows a link which caused a timeout: https://pastebin.com/9FCBgGHq
So I think maybe it will work if I change the source: files.pythonhosted.org.
Which file can I modify to switch to another source?

You should better figure out why you can't download packages from PyPI. I would not trusted any other repository. Do you have any firewall or network filter running yourself or somewhere within your organization?

Now I can install plone after switching to another ISP.

Thanks

Plone Foundation Code of Conduct