Plone 5.2.2 All icons are missing

Hello All,

I am hoping to find a quick answer as to what is going on with my site. Suddenly, all the icons are missing from the toolbar and site admin area (see screen shots below). They all appear just fine when in Development Mode but are gone in production mode. I have spent the better part of a full week going through different forums but have been unable to find the answer.

I am not a coder or developer by any means and so, admittedly, a lot of what I have read has gone over my head a little bit.

This issue occurred when I followed a guide to change the color of the text of 'plone-toolbar-internally-published-color' less variable. Entered Development Mode, turned on Develop CSS for Plone, changed the RGB value only in the less variable, saved, ran 'build', turned off development and refreshed and voila, all icons gone.

Turning dev mode back on brings the icons back and the color shows up the way I want, turn off dev mode, color reverts back to the default and icons all disappear.

I have tried running bin/buildout, restart the server as well, going through what files I can find but nothing seems to fix the issue. A similar issue was referenced here Plone 5.1.6: All icons suddenly boxes but did not provide a fix for me. Any help at all would be greatly appreciated.


You can try:

  1. Go to the theming control panel
  2. Disable the current theme
  3. Enable the same theme
  4. Go to 'resource registry control panel' ( /@@resourceregistry-controlpanel )
  5. Enable debug mode

Check if this works.

  1. Disable debug mode.

Hey There, thanks for your response!!

I assume Debug Mode would be Development Mode and not what is referenced here?

That process made it different it looks like but still not correct. Previously, the missing icons instead were boxes with E### in each of them but now they are simply empty boxes. Just an empty rectangle.

Disregard my question about debug vs dev mode. I see they are one in the same :slight_smile:

About debug mode: I meant debug mode in the registry control panel

go to and click the 'debug mode button', and save.

A little info:
The icons you (dont) see are not images, but a font. So probably(?) the font gets replaced, maybe because it could not load. Or another version of the font has been loaded (see screenshot).

Yes, the plone-fontello.woff and plone-fontello.ttf font files give a 404 when in production mode, but not in debug mode. I have seen this on a bunch of 5.2 sites. Even just upgrading from 5.2.1 to 5.2.3 all the icons are gone.

Other than the debug mode workaround, I don't have a solution.

Additional information:

The fontello font files load fine in either of these cases:

  1. The resource registry is in development mode and the site is started in production mode (i.e. background).
  2. The site is started in fg mode and it doesn't matter whether the resource registry is in development mode or not.


I have seen a similar issue with font based icons only displaying on the navigation bar when the resource registry was in dev mode.

I managed to fix this issue by:

  • Go to the ZMI >> PLONE_SITE >> portal_resources
  • Rename the "static" and "production" folders
  • Go to the Resource Registry Control Panel and turn debug mode on and then off (This should regenerate the "static" and "production" folders)

Not sure if this fix applies to your issue?

The original problem is discussed at:

1 Like

Yes, that worked!
Thank you so much.

Only minor correction:

  • Go to the ZMI >> PLONE_SITE >> portal_resources >> resource_overrides >> Edit
1 Like

YES THANK YOU!! This was put on the back burner while other projects and issues were worked on. Just tried the fix now and it worked like a charm. Thanks so much for sharing this.


1 Like