Plone 5.2.14 on OS with Python3.10 only


I used to have a Plone 5.2.9 site installed on a Linux Mageia 8 OS. Because the latter was not maintained anymore, I had to upgrade it to Mageia 9 but this one provides Python10 only, which is not supported by Plone 5.2.14. So I manually installed Python3.8 from Python Release Python 3.8.10 | with:

./configure --enable-optimizations
sudo make install

I then tried to install Plone 5.2.14 with:

./ --with-python=/usr/local/bin/python3.8

but that failed with:

Plone Unified Installer

Continue with the command line: standalone \
    --target="/home/gest/site-gte-mga9-5.2.14/" \

1) Yes
2) No
#? 1

Testing /usr/local/bin/python3.8 for Zope/Plone requirements....
Failed: This Python does not have ssl support.
If you want to disable this check, add --without-ssl=yes
to the command line.
Warning: This Python does not have readline support.
It may still be usable for Zope, but interacting directly with Python will be painful.

/usr/local/bin/python3.8 does not meet the requirements for Zope/Plone.

Please do one of the following:
1) Install python3.8 or python3.6+ as a system dev package\;
2) Use --with-python=... option to point the installer to a useable python.

What could I do now?


The error message is self-explaining.

Ah, thanks. Do you know how to make Python 3.8 manually installed have ssl support?

libssl or openssl including their -dev packages must be installed before compliation.

Hi! Here the prerequisites libraries for Plone 5.2.14:

You've to install the readline dev package before compiling, so you can compile it with readline support.

Note: the installer can compile its own Python 3.8 version but still needs the prerequisites.

1 Like

With all the prerequisites, it works now: thanks.

1 Like