Plone 5.1rc2 HELP! Can't Save changes to Page with Mosaic "Save" button

Not really sure where to go with this one.
I've opened an existing page on (the home page) and edited some text in the left column.
But the Save button does nothing.
Cancel cancels, Properties brings up properties...
But Save does nothing.
What is up with this???
Same problem in multiple browsers.
I duplicated the page, tried editing the new copy. No joy.
Retracted the page to internal state, no Joy.
Any clues!?

If I switch to "view Document" display, I can edit , and switch back to Mosaic, which solves the immediate critical concern. However, there is a serious functional problem here.
The site is pretty much generic regarding anything other than Mosaic in the editing/display add-ons.

If you open your browser's console (depends on the browser, but it could be Inspect mode) is there an error shown? Could be a JavaScript loading error, for example.

Otherwise, what's changed since the last time it worked?

1 Like

Were you able to figure this out?

Not yet.... I'll have to revisit when I get back to the frozen tundra next
week :slight_smile:

Cheers from Mendocino!


1 Like

Still having serious usability issues with Mosaic in FIrefox Quantum (60.0b5) and Safari 11.0.3.
The problem does not show up in Chrome 65.0.3325.181.

Plone 5.1rc2 2.0rc8 4.1.1 3.0.3

I'll have to check for more recent versions...

For the record, that's my pins on 5.1rc2, which work on Firefox (don't have Safari, Linux user...)

plone.tiles = 2.0.0b3
plone.subrequest = 1.8.1 = 3.0.3 = 2.2.0 = 4.1.1 = 1.1.2 = 2.0rc8
plone.formwidget.multifile = 2.0
plone.jsonserializer = 0.9.5

1 Like

If you don't get that to work:

If you add a new page, can you then edit and save with the same tiles ?

1 Like