Plone 5.1.6 pas.plugins.ldap 1.8.0 do not work together on Windows server

Hello,
On a Windows 2016 server, I installed plone 5.1.5 and pas.plugins.ldap 1.6.2 via buildout. Everything settled down well. Indeed when I connect to the ZMI of plone 5.1.5 then acl_users,
I have LDAP-Plugin which allowed me to configure it.
Everything works well with Active Diretory.
However on the same server, I installed plone 5.1.6 and via buildout
pas.plugins.ldap 1.8.0.
But when I connect to the ZMI, there is no LDAP-Plugin.
So no way to communicate with Active Directory.
My question has anyone tried? If so, the problem is with plone 5.1.6 or pas.plugins.ldap 1.8.0.
Thank you in advance for your help.

Right, pas.plugins.ldap was never tested on Windows.

This is mainly because of two reasons: 1) the underlying python-ldap has only inofficial builds for Windows and 2) we, the authors, developed this add-on to full-fill our paying customers needs, enhancing it with every project. Unfortunately we never had a customer with Windows as target platform.

That said, it is probably possible to make it work on Windows.

Due to the projects enterprise-need nature, it is a kind of "insert-coin-to-continue" project and all contributions where made in this sense. Either most contributions came in from larger organizations themselves or by projects done by smaller companies for larger orgs. But some where done also by crowsfunding.

Hello,
Thank you for the clarification.
If pas.plugins.ldap 1.8.0 does not work with Plone 5.1.6 while pas.plugins.ldap 1.6.2 works perfectly with Plone 5.1.5 on Windows server (and Windows 10), to ensure authentication via Active Directory, what other efficient tool do we have as an alternative solution under plone 5.1.6 and Windows?
I thank you all in advance for your help.

By the way: If it does not work and it worked before (even if never tested on Windows officially), then your asking the wrong questions. Better tell whats wrong, provide tracebacks (use markdown formatting features to make them look nice). Also it is a good idea to the issue tracker https://github.com/collective/pas.plugins.ldap/issues to report the regression.
This just as a hint.

I submitted the issue to the community at the URL shown.
Thank you.

1 Like

Plone Foundation Code of Conduct