Plone 5.1.4 - After Installing Archetypes Content Types 2.3.8 no more Dexterity Types available

In a tollay new installed Plone 5.1.4 instance with a newly created Plone Site: As soon as I activate Archetypes Content Types 2.3.8 there are no more Dexterity Types listed in the Dexterity Content Types setup section. And I can not add any NewsItem, Folder or other content type object.
This behaviour persists even after having uninstalled Products.ATContentTypes 2.3.8.

I could not yet find any thread about that.
Does anyone know, what the source of that problem is? Is it a bug? Any fixes available?


Why do you want Archetypes on a new system?

We want to import Folders from an earlier Plone Site. This works fine with Products.ATContentTypes but not without it.

Just to add this information: The described problem did not occur in early Plone 5 Versions, e.g. Plone 5.0.7 (5017).

You know that you can not import (ZEXP import/export) between different Zope/Plone versions.

Yes, I know that this is written in the descriptions. But in Plone 5.0.7 with Products.ATContentTypes activated we could ZOPE-import folders from earlier PLONE Versions and then run the AT-to-DX Type conversion tool and everything worked fine.

But independent of that question: Products.ATContentTypes 2.3.8.Plone 5.1.4 is by default in the list of installable add-ons of Plone 5.1.4, so it should work if someone activates it in the setup.

Pro-Tipp: forget Archetypes as of today.

Perform a proper export of your data e.g. using collective.jsonify and use e.g. transmogrifier for a proper import into Dexterity content-types.

We migrated a bunch of sites (including partial content) with a script that runs against the old Plone site and inserts the data as new content over plone.restapi.

Everthing else sounds like broken-by-design nowadays.

Thanks for this hint, Andreas.
I already tried migrations using collective.jsonify and transmogrifier. I thought to have done everything as described in the prober descriptions, but was even after several attempts not successful. If you were successfull that way, I'll try it again and would allow myself to contact you, when I run into problems. Ok?

You have my contact in case you need it.

How about trying

The preconditions are unlikely met here

It's not yet ready for production use.
And it's not yet designed for AT to DX conversion (but it would be good to know what is needed to make that work well)