Plone 5.1.2 Mosaic does not Save edits (OSX 10.13.5 Chrome Version 67.0.3396.87 )

I have just (finally) successfully updated my test server to Plone 5.1.2 (after pinning plone.protect=3.1.2)

However, the problem I was hoping to resolve still lingers.
When I edit a Mosaic layout in a site, the save button throws the following JS errors (in OS X Chrome)

Or perhaps it's not the Save button, but this error which prevents the Save button from functioning.
But the Cancel button cancels the edit, and nothing is saved.
How to resolve this!?
I've tried retracting the page (to private) before editing, this doesn't change anything...
Any other hints!?

logged-in.js:formatted:16891 Uncaught TypeError: Cannot read property 'parse' of undefined
at hk.setContent (logged-in.js:formatted:16891)
at p.saveForm (plone-mosaic.js:198)
at p._change (plone-mosaic.js:198)
at p.blur (plone-mosaic.js:198)
at HTMLDivElement.<anonymous> (plone-mosaic.js:200)
at Function.each (default.js:2)
at m.fn.init.each (default.js:2)
at Object.exec (plone-mosaic.js:200)
at HTMLButtonElement.<anonymous> (plone-mosaic.js:200)
at Function.each (default.js:2)

you are not alone, this is without doubt the same problem:

You should google this forum, this has been discussed before.

I am pretty sure someone had a similar problem due to wrong versions of tiles/blocks etc

(see )

Great, thanks very much Espen, I will pin some versions this morning

I've pinned the mosaic components per your pointer and rerun buildout...
Have also removed a bunch of other components from the buildout hoping that would help.
It has not.

I am getting very sad about not being able to edit my plone site at all for months now.
Not a developer, just a lowly admin, I am running a plone 5.1.most-recent buildout, and have tried just about everything to be able to edit the pages again.

I guess I just need to know if Plone+Mosaic is really ready for prime-time.
With the experience I'm having, I'd never in a million years recommend it to a client or end-user.
What is it about Plone which seems so fragile? It's robust in so many ways, but I have never had a Plone 5 site that actually worked as desired.
Constant struggles and frustrations.
Should I just forget about Plone, since I will never have the time or expertise to patch the fibers and upgrade the trilithium crystals?

I am a competent *nix admin, no problem following directions, but this ecosystem may just be beyond my capacities. :frowning:


Mosaic 2 has been stuck in beta for a very long time and from what I understand it was committed out of this state by another developer that the main developer because a release was needed. So while it is officially out of beta it's not sure that it is so stable in fact since no formal process like a release candidate has been done.

As of your problem I have at least an idea to test (I'd like to see if the change I experimented with Tinymce initialization has an effect) but what is keeping me is the time needed to setup a test bed (install mosaic, setup the site, add some content so that I can reproduce the problem). Reproducing the problem is sometimes longer than fixing it and can be a bit frustrating sometimes (works for me, so what is not working for others ?)
So if you have more precise instructions on how to reproduce the problem it could get me in action.

1 Like

Mm. Would it be helpful if I give you access to my development server?
It's a DIgital Ocean droplet.
I was about to make a new Plone instance there, and see what if any differences show up with a generic Plone+Mosaic site.
Drop me a private note at if that would be useful.
Let me know, I'd love to see this get figured out, but as I'm completely without a clue re the Mosaic architecture, all I can do is beg for advice!

Mosaic works in general. The only problem I know is when you create custom layouts and save them. Pages based on them can sometimes have the problem that the data will not be saved. That Happens when you create a page, save it and later finish the layout and then save it. To have it working, create a page, finish the layout and save it right away, without save the page before. Then you can use the saved layout and everything works fine. Sure it's not perfect and need to be fixed, as soon someone finds the time.

1 Like

I'm not at ease with the idea to be candid.
is the advice from @MrTango helpful ? if not I think it gives me some directions on how to reproduce the problem on a test server.

1 Like

@gp54321 OK, well, this 'development server' is merely a Digital Ocean droplet which is a clone of my production server.
It's easy to recreate, and not at all precious :wink:

@MrTango Thanks for the tip!
It does seem like a pretty important issue, if Mosaic is supposed to be part of the Plone OOTB experience.
I know it's all volunteer, and it's incredibly impressive indeed, but these issues become showstoppers for end-users and non-developers trying to use the platform...

I very much appreciate the input. Perhaps this advice should be H1 FF0000 at the beginning of the Mosaic docs.

What can I do to help?
Plone's codebase is incredibly dense, one needs to have had years of background with the Zope/Plone architecture to make any sense of it...
All I can do is try to carefully document the problems, and hope and pray that there is some solution other than rebuilding my sites from scratch in some other platform.
Sorry, I don't mean to be snarky, I do understand how it works.
Just a bit surprised that such a fundamental issue — Does Not Save — is not a top critical issue.

A detailed bug report would help us to identify the technical problem. It looks related to

well, it may not be a problem if it's destroyed, yet it is a copy of your prod data. And your passwords are saved on it. I'd not be very keen to go for it if it was my data, and never if if it was someone else data, so I don't feel confortable.
This said, I tried to reproduce with @MrTango tips and so far I am not successful, that is, it works and I don't see the problem. This said my test page is a very simple page, so probably there is something else to do to trigger the bug. I am not giving up, just that I have other things to do, I have to think more about it and get some more practice with mosaic.
On your test instance is there a way to reproduce the problem with fresh data and fresh layout ?

Thanks for explaining!
As I noted I'll be away from this for a few weeks.
Will try to catch up and dig further into it when I get back!
Btw, although I express my frustration with Plone, I've never had anything
but fantastic interactions with the community. If only all the world's
complex problems could be addressed through the model so well shown here.
Deep bow of appreciation!

1 Like

there are some newer version also with fixes, please try if you can still reproduce the errors.
Also test if it's possible to reproduce the errors on a fresh Plone site.
It might be that you have some bad data, because of bad version matching in the past.
So let's find that out first.

Thanks, I'll look into this in August when I get back to the office!

..translates to: unusable in production. Mosaic is still in same weird state as I have seen it a year ago. Not much progress and far away from being ready for public consumption. Sad but that's how open-source works.

@pfraterdeus a good way to help others trace the source of the problem would be for you to post your buildout.cfg and the smallest possible set of steps required for us to reproduce the problem. ...unless of course your problem sounds like the ones mentioned above for which there is already a ticket

Rereading your post title, I wonder if you are seeing the problem with other browsers too (Safari, Firefox)

Yes all browsers. The problem is well defined above in Maik's post.
I will of course post the buildout if that will be useful.
Many thanks!